Search found 52 matches

by TaliG
Wed Oct 07, 2020 5:15 pm
Forum: Flowcode V8
Topic: Modbus TCP slave cannot reconnect after disconnection
Replies: 0
Views: 78

Modbus TCP slave cannot reconnect after disconnection

Hi Benj! I try to find a way to restart modbus comms after saden disconnect (unplug cable) either from slave or master.. At the moment I can sense the disconnection using the "Get socket status" function, if it is anything other than 23 decimal then I trigger a function to reconnect, but nothing I u...
by TaliG
Tue Sep 29, 2020 5:01 pm
Forum: Flowcode V8
Topic: Modbus tcp/ip master/slave simulation problem
Replies: 38
Views: 6286

Re: Modbus tcp/ip master/slave simulation problem

Hi kabouras! Modbus TCP protocol replies are already fixed by Benj. At least w5500 works fine for me (communicates correctly with modbus poll). Please take a look at this thread https://www.matrixtsl.com/mmforums/viewtopic.php?f=78&t=22101 and download my test flowchart using w5500 that works great ...
by TaliG
Sat Sep 26, 2020 1:32 pm
Forum: Flowcode V8
Topic: PIC24fj256GA406 RS-485 Based Modbus RTU
Replies: 10
Views: 402

Re: PIC24fj256GA406 RS-485 Based Modbus RTU

Hi, In your schematic you are using a max13487 transceiver. This chip has a build in state machine for auto direction control. You do not need to use the DIR pin from your microcontroller. Just connect the the RE and SHDN pins according to max13487 datasheet and use RS232 ttl method instead RS485 in...
by TaliG
Wed Sep 16, 2020 4:50 pm
Forum: Flowcode V8
Topic: PIC24fj256GA406 RS-485 Based Modbus RTU
Replies: 10
Views: 402

Re: PIC24fj256GA406 RS-485 Based Modbus RTU

Hi! Can you explain what you are trying to accomplish please? eg, I would like to read something from my hardware and see it on modbus poll. Can you also confirm the following please? 1. Modbus poll is the master and PIC24 hardware is the slave. 2. Connection from your PC is a usb to rs485 dongle to...
by TaliG
Tue Sep 15, 2020 7:54 pm
Forum: Feature Requests
Topic: Slave EtherCat
Replies: 5
Views: 217

Re: Slave EtherCat

Hi Benj! As a master I am using a raspberry pi running codesys. This way I can be sure my project will be able to run on any commercial PLC that supports codesys. I can build and debug my project without having to buy the target PLC and work on it. Then when the automation hardware is in place it is...
by TaliG
Fri Sep 11, 2020 2:29 pm
Forum: Feature Requests
Topic: Slave EtherCat
Replies: 5
Views: 217

Re: Slave EtherCat

Hi Benj! Thank you for investigating this. I know this is kind of a big project.. Unfortunately I have never used an arduino before. I do not think I am going to use one in the near future either. I am very comfortable with 8-16bit pics and currently study the STM32 platform. This arduino shield in ...
by TaliG
Sun Sep 06, 2020 4:20 pm
Forum: Feature Requests
Topic: Slave EtherCat
Replies: 5
Views: 217

Slave EtherCat

Slave EtherCat component with microchip LAN9252 or other.
easyCAT module from AB&T has code examples for most if not all platforms.
maybe create a new "industrial comms module" that includes industrial comms?

George
by TaliG
Mon Jun 29, 2020 5:45 pm
Forum: Bug Reports
Topic: Modbus TCP slave invalid response
Replies: 12
Views: 1133

Re: Modbus TCP slave invalid response

Hi Ben! I think you nailed it (again). I tested only with ModbusPoll but I think the response frame is correct now. I will test with Codesys and raspberry pi and report back but I am pretty sure it is going to work fine. Now about the hardware and the w5500 module not replying back to any request fr...
by TaliG
Tue Jun 23, 2020 3:51 pm
Forum: Bug Reports
Topic: Modbus TCP slave invalid response
Replies: 12
Views: 1133

Re: Modbus TCP slave invalid response

Hi Ben!

Can you acknowledge the "number of bytes that follow" or "message length" bug pls?
At the moment I thing you just echo those bytes from the master request which is wrong.

thanks
George
by TaliG
Fri Jun 19, 2020 4:03 pm
Forum: Flowcode V8
Topic: MPU6050
Replies: 26
Views: 2537

Re: MPU6050

yes in your windows device manager. when you connect your module to your pc, can you hear the usb connected windows sound? have FC8 and mloader closed before you do that. If your module connects to your pc you should be able to find it in the windows device manager and when you do, right click and u...
by TaliG
Fri Jun 19, 2020 3:35 pm
Forum: Flowcode V8
Topic: MPU6050
Replies: 26
Views: 2537

Re: MPU6050

Hi Jorgen, Go into windows settings, then devices, find your device and uninstall it. Unplug your device and replug it. Let windows reinstall the drivers. Now check if you can use your device within FC8. I had problems programming my EB091 last night and as I was about to post into the bugs section,...
by TaliG
Thu Jun 18, 2020 7:42 pm
Forum: Bug Reports
Topic: Problem with latest update
Replies: 13
Views: 1095

Re: Problem with latest update

Cheers Steve

I think problem is solved
by TaliG
Wed Jun 17, 2020 3:16 pm
Forum: Bug Reports
Topic: Problem with latest update
Replies: 13
Views: 1095

Re: Problem with latest update

H Steve, After a couple of reinstallations I have the same problem. I also noticed that the modbusTCP slave component update was removed (it was actually making the component completely disappear from flowcode after updating). Reverting back to previous versions does not work. In any case modbus tcp...
by TaliG
Mon Jun 15, 2020 2:13 pm
Forum: Bug Reports
Topic: Problem with latest update
Replies: 13
Views: 1095

Re: Problem with latest update

Cheers Steve!!

George
by TaliG
Mon Jun 15, 2020 2:11 pm
Forum: Flowcode V8
Topic: Update Problems
Replies: 2
Views: 253

Re: Update Problems

Hi, it is going to be fixed soon.
viewtopic.php?f=78&t=22164
by TaliG
Sat Jun 13, 2020 10:02 pm
Forum: Bug Reports
Topic: Problem with latest update
Replies: 13
Views: 1095

Re: Problem with latest update

Hi Martin I already did that. It did not work.

Then I went ahead and reinstall with the installer I downloaded from inside my account. Problem remains.
The public installer download page does not work, returns an error when trying to download.

Thanks

George
by TaliG
Sat Jun 13, 2020 7:45 pm
Forum: Bug Reports
Topic: Problem with latest update
Replies: 13
Views: 1095

Problem with latest update

Hi,

after I updated through the online updater service, the updated files and components current revision "not genuine".
Also the modbusTCP slave component disappeared from the comms tab and is not function anymore in my project.
I did a clean install of flowcode and the problem remains.

George
by TaliG
Tue May 26, 2020 6:44 pm
Forum: Flowcode V8
Topic: MAX31864 SPI
Replies: 23
Views: 2426

Re: MAX31864 SPI

Hi Jorgen this is not privet, I thought it would be better if I cleaned the flowchart from other irrelevant tasks before I upload. My goal is to declutter the flowchart and make it understandable enough for someone who is familiar with component creation , so he can build a flowcode component with i...
by TaliG
Tue May 26, 2020 4:24 pm
Forum: Flowcode V8
Topic: MAX31864 SPI
Replies: 23
Views: 2426

Re: MAX31864 SPI

Hi
PM send.
by TaliG
Mon May 25, 2020 11:30 pm
Forum: Flowcode V8
Topic: MAX31864 SPI
Replies: 23
Views: 2426

Re: MAX31864 SPI

Hi kabouras,

I do have a working example for max31865 but includes LODS of code irrelevant to this sensor.
I will take out all the irrelevant code to the sensor and upload it for you this weekend.

George
by TaliG
Sat May 23, 2020 6:26 pm
Forum: Bug Reports
Topic: Modbus TCP slave invalid response
Replies: 12
Views: 1133

Re: Modbus TCP slave invalid response

Hi Benj, I tested again today modbus TCP slave simulation with modbus Poll and I think I found the problem. Flowcode simulation always replies with incorrect message length byte. e.g. server request to read 2 analog inputs starting from address 0: TX: 00 01 00 00 00 06 01 04 00 00 00 02 00 01 transa...
by TaliG
Sun May 17, 2020 11:52 pm
Forum: Bug Reports
Topic: Modbus TCP slave invalid response
Replies: 12
Views: 1133

Re: Modbus TCP slave invalid response

Hi Benj, I tested today and the results are the following. --Server: modbusPoll-- Simulation responds nicely to modbus Poll software. So I guess the modbusTCP and netcomsComponents works as intended after the update. On hardware, the W5500 connects but never reply to any request. modbus Poll can onl...
by TaliG
Fri May 15, 2020 8:24 pm
Forum: Bug Reports
Topic: Modbus TCP slave invalid response
Replies: 12
Views: 1133

Re: Modbus TCP slave invalid response

Hi Benj,

great support as always.

Working from home together with your litle prince or princes is a monumental task.
I definitely wouldn't be able to do that.

I will report back as soon as I test your solution.

Thanks again for your great support.
by TaliG
Mon May 11, 2020 5:01 pm
Forum: Bug Reports
Topic: Modbus TCP slave invalid response
Replies: 12
Views: 1133

Modbus TCP slave invalid response

Hi, I am trying to convert a Modbus RTU serial slave flow (rpiRTU) into Modbus TCP slave (rpiTCP). I am using EB091 plus W5500 module for slave. Master is a raspberry Pi programed with codesys, also modbus Poll is used to poll the slave. UART ModbusRTU (rpiRTU) works very well on real hardware. Modb...
by TaliG
Sat May 02, 2020 8:43 pm
Forum: Flowcode V8
Topic: Modbus tcp/ip master/slave simulation problem
Replies: 38
Views: 6286

Re: Modbus tcp/ip master/slave simulation problem

Dear Benj, I am stuck with the same problem. I am using Codesys with rasberryPi as a Master, EB091 plus W5500 as a slave. ModbusTCP with W5500 gives invalid header response. UART Modbus RTU works great. Any news on a fix? Thanks! rpiRTU.fcfx works great rpiTCP.fcfx connects but returns wrong respons...