Search found 35 matches

by TaliG
Tue May 26, 2020 6:44 pm
Forum: Flowcode V8
Topic: MAX31864 SPI
Replies: 23
Views: 1137

Re: MAX31864 SPI

Hi Jorgen this is not privet, I thought it would be better if I cleaned the flowchart from other irrelevant tasks before I upload. My goal is to declutter the flowchart and make it understandable enough for someone who is familiar with component creation , so he can build a flowcode component with i...
by TaliG
Tue May 26, 2020 4:24 pm
Forum: Flowcode V8
Topic: MAX31864 SPI
Replies: 23
Views: 1137

Re: MAX31864 SPI

Hi
PM send.
by TaliG
Mon May 25, 2020 11:30 pm
Forum: Flowcode V8
Topic: MAX31864 SPI
Replies: 23
Views: 1137

Re: MAX31864 SPI

Hi kabouras,

I do have a working example for max31865 but includes LODS of code irrelevant to this sensor.
I will take out all the irrelevant code to the sensor and upload it for you this weekend.

George
by TaliG
Sat May 23, 2020 6:26 pm
Forum: Bug Reports
Topic: Modbus TCP slave invalid response
Replies: 8
Views: 163

Re: Modbus TCP slave invalid response

Hi Benj, I tested again today modbus TCP slave simulation with modbus Poll and I think I found the problem. Flowcode simulation always replies with incorrect message length byte. e.g. server request to read 2 analog inputs starting from address 0: TX: 00 01 00 00 00 06 01 04 00 00 00 02 00 01 transa...
by TaliG
Sun May 17, 2020 11:52 pm
Forum: Bug Reports
Topic: Modbus TCP slave invalid response
Replies: 8
Views: 163

Re: Modbus TCP slave invalid response

Hi Benj, I tested today and the results are the following. --Server: modbusPoll-- Simulation responds nicely to modbus Poll software. So I guess the modbusTCP and netcomsComponents works as intended after the update. On hardware, the W5500 connects but never reply to any request. modbus Poll can onl...
by TaliG
Fri May 15, 2020 8:24 pm
Forum: Bug Reports
Topic: Modbus TCP slave invalid response
Replies: 8
Views: 163

Re: Modbus TCP slave invalid response

Hi Benj,

great support as always.

Working from home together with your litle prince or princes is a monumental task.
I definitely wouldn't be able to do that.

I will report back as soon as I test your solution.

Thanks again for your great support.
by TaliG
Mon May 11, 2020 5:01 pm
Forum: Bug Reports
Topic: Modbus TCP slave invalid response
Replies: 8
Views: 163

Modbus TCP slave invalid response

Hi, I am trying to convert a Modbus RTU serial slave flow (rpiRTU) into Modbus TCP slave (rpiTCP). I am using EB091 plus W5500 module for slave. Master is a raspberry Pi programed with codesys, also modbus Poll is used to poll the slave. UART ModbusRTU (rpiRTU) works very well on real hardware. Modb...
by TaliG
Sat May 02, 2020 8:43 pm
Forum: Flowcode V8
Topic: Modbus tcp/ip master/slave simulation problem
Replies: 34
Views: 4480

Re: Modbus tcp/ip master/slave simulation problem

Dear Benj, I am stuck with the same problem. I am using Codesys with rasberryPi as a Master, EB091 plus W5500 as a slave. ModbusTCP with W5500 gives invalid header response. UART Modbus RTU works great. Any news on a fix? Thanks! rpiRTU.fcfx works great rpiTCP.fcfx connects but returns wrong respons...
by TaliG
Wed Aug 22, 2018 1:08 pm
Forum: 16-Bit PIC
Topic: dsPIC33EP512MU810 PWM remapable pins
Replies: 2
Views: 1886

Re: dsPIC33EP512MU810 PWM remapable pins

Hi Benj Thank you for your answare. Only reason I asked, was because I made a small development pcb and used RE6 as a pwm output as it is listed as PWM4L in the datasheet so I thought I could use it as a pwm output. I guess the only way to produse a pulse on this pin will be through the use of a tim...
by TaliG
Wed Aug 22, 2018 10:36 am
Forum: Bug reports
Topic: PIC18F26K40 I2C LCD not working
Replies: 7
Views: 2694

Re: PIC18F26K40 I2C LCD not working

Hi,
sorry for late reply.

on the 47k40 I used external 20mhz oshilator without PLL.
also tried the internal oschilator with no luck.

In anycase, I moved all my projects on a EB091 and im so huppy i do not think I will ever go back to 8bits again :)

Regards
George
by TaliG
Wed Aug 22, 2018 10:29 am
Forum: 16-Bit PIC
Topic: dsPIC33EP512MU810 PWM remapable pins
Replies: 2
Views: 1886

dsPIC33EP512MU810 PWM remapable pins

Hi,

In the PWM remapable pins drop down menu,
Is it possible to add RE1, RE3 and RE6 please?

Thanks
by TaliG
Sun Aug 19, 2018 8:41 pm
Forum: Bug reports
Topic: PIC18F26K40 I2C LCD not working
Replies: 7
Views: 2694

Re: PIC18F26K40 I2C LCD not working

Hardware i2c and spi never worked on any 18FxxK40 devices.
software works fine as it is "software''.
Also on 18F67K40 you cannot print string values on an alphanumeric lcd connected using either 4 or 8bit mode (no i2c or spi).
by TaliG
Wed Feb 14, 2018 11:41 am
Forum: Bug reports
Topic: Harware I2C on pic18f47k40 cannot start
Replies: 0
Views: 885

Harware I2C on pic18f47k40 cannot start

Hi,
I2C channels 1 and 2 cannot start.
Microcontroller hangs.
by TaliG
Fri Feb 09, 2018 7:15 pm
Forum: Bug reports
Topic: PIC18F47K40 ds3231rtc
Replies: 2
Views: 821

Re: PIC18F47K40 ds3231rtc

Thank you for your reply.
I can now set pins, but I2C does not work.
Checked with oschiloscope also.

Software I2c works fine.
by TaliG
Fri Feb 09, 2018 12:31 pm
Forum: Bug reports
Topic: 20x4 lcd component cannot print string
Replies: 0
Views: 883

20x4 lcd component cannot print string

Hi,

on 18f67k40 harware

the 20x4 lcd component cannot print string values.
Simulation works but it does not work on hardware.

Numbers and Ascci print fine on both simulation and hardware.

This happens both in 4bit and 8bit generic modes.
by TaliG
Thu Feb 08, 2018 7:19 pm
Forum: Bug reports
Topic: PIC18F47K40 ds3231rtc
Replies: 2
Views: 821

PIC18F47K40 ds3231rtc

Hi,

It is not possible to choose SDA and SCL pins.
by TaliG
Thu Feb 08, 2018 7:08 pm
Forum: Bug reports
Topic: PIC18F67K40 ds3231rtc
Replies: 0
Views: 811

PIC18F67K40 ds3231rtc

Hi, I cannot get I2C ch1 and ch2 to work with the rtc. Microcontroller halts on the first read request. Software I2C works but not as expected either. reading and printing as string gives 000000 instead of 00:00:00 form. The same harware on a 16f887 works perfectly fine. here is a small test flowcha...
by TaliG
Thu Aug 17, 2017 6:36 pm
Forum: Bug reports
Topic: some 18F67K40 compilation errors
Replies: 5
Views: 2439

Re: some 18F67K40 compilation errors

Hi Ben!

All good! :D
No more compilation errors!!

Thanks alot!!

George
by TaliG
Thu Aug 17, 2017 2:47 pm
Forum: Bug reports
Topic: some 18F67K40 compilation errors
Replies: 5
Views: 2439

Re: some 18F67K40 compilation errors

Hi Ben,

Did you have any chance to look at those compilation errors?
Is there a possibility to include a fix together with your next (bug fix-new features) update please?

Thanks!
by TaliG
Fri Aug 11, 2017 1:49 am
Forum: Feature requests
Topic: watchdog timer component
Replies: 2
Views: 2326

Re: watchdog timer component

hi Ben! I am ashamed :oops: (cause of my laziness) It could be a component with 2 functions .One function to setup the timer and one more to reset it. Auto reset function would be counter productive as i imagine it would eat a timer interupt to do that., please disregard ... what I realy wish Santa ...
by TaliG
Fri Aug 04, 2017 7:53 pm
Forum: Feature requests
Topic: watchdog timer component
Replies: 2
Views: 2326

watchdog timer component

I know it is a huge work, going through countles devises.. but I have faith on you guys. You did and continue to do extraordinary things for us. I beleive in Santa C. :) love you all and I COMAND YOU to forget everything for a week or 2,3 and have fun with your family this summer, feel the sea!!! SH...
by TaliG
Wed Jul 26, 2017 5:01 pm
Forum: Bug reports
Topic: some 18F67K40 compilation errors
Replies: 5
Views: 2439

Re: some 18F67K40 compilation errors

Hi,

here is a flowcode exaple that can produce the compilation errors I previously posted plus errors of I2c, SPI, UART. It is not my main project , but I think it shoul help.
I am actualy migrating a flowcode project from 18f47k40 to this new one (pins are never enough :) )

Thanks!
by TaliG
Tue Jul 25, 2017 7:28 pm
Forum: Bug reports
Topic: some 18F67K40 compilation errors
Replies: 5
Views: 2439

some 18F67K40 compilation errors

Hi, I started playing with this new device and had the following compilation errors: 1. C:\Program Files (x86)\Flowcode 7\CAL\PIC\PIC_CAL_ADC.c: FC_CAL_ADC_Disable() 5583: ANSELC = 0x00; ^ (192) undefined identifier "ANSELC" 2. 12132: IOEBP=0xFF; ^ (192) undefined identifier "IOEBP&qu...
by TaliG
Mon Jul 03, 2017 4:00 pm
Forum: Bug reports
Topic: Timer interrupts calling a macro
Replies: 3
Views: 1631

Re: Timer interrupts calling a macro

what i already do is using a swich inside the macro, is this correct? thank you for your help!
by TaliG
Mon Jul 03, 2017 2:29 pm
Forum: Bug reports
Topic: Timer interrupts calling a macro
Replies: 3
Views: 1631

Timer interrupts calling a macro

Hi, I do not know if this is a bug, or im doing something wrong, or it cannot be done. When I am enabling a timer interrupt and calling a macro, then disabling this interrupt all goes well. Then I would like to use the same timer for enother interrupt, re enabling the timer interrupt (same timer) ca...