Search found 47 matches

by CSM2711
Thu Oct 24, 2019 6:32 am
Forum: Flowcode V8
Topic: Problems PIN selsection internal CAN 18F26k80
Replies: 3
Views: 768

Re: Problems PIN selsection internal CAN 18F26k80

Ok I understand.
But i have now another problem...
i wrot a simple test programm (see attachmend) but when I Start my CAN software i will get no data only stuff errors.......
I testetd the same with external CAN (MCP2515) an every thing works fine.
Anyone an Idea?
by CSM2711
Wed Oct 23, 2019 7:41 am
Forum: Flowcode V8
Topic: Problems PIN selsection internal CAN 18F26k80
Replies: 3
Views: 768

Problems PIN selsection internal CAN 18F26k80

Hello, I have some problems using the internal can module of PIC18F26K80. I get no CAN meesages...... But I wonder in the datasheet and the chip view the CANRX PIN is RC7 and the CAN TX Pin is RC6. In the can component the PINS B2 and B3 are selescted and it is not possible to select another pin. Is...
by CSM2711
Mon Sep 23, 2019 7:37 am
Forum: Flowcode V8
Topic: Problems selecting Simulation Pin for interrupt
Replies: 1
Views: 538

Problems selecting Simulation Pin for interrupt

hello, I have the following problem. while activating the interrupt I can select any pin for the interrupt, but for the simualtionpin I can only select RA0.
Is this a bug or do I not understand something here?
by CSM2711
Mon Sep 16, 2019 10:05 am
Forum: Flowcode V8
Topic: problems understanding / using modbus component
Replies: 1
Views: 507

problems understanding / using modbus component

Hi, I'm trying to get a modbus communication right now, unfortunately I have an understanding problem here. I hope someone can help with this. I use the valve from the appendix. Now I want to change the setpoint (register 0x0004,0x00005). Here I would have to send the following string: SlaveID: 1 Fu...
by CSM2711
Mon May 13, 2019 7:44 am
Forum: Flowcode V8
Topic: Problems usin SW Chanel of CAL Uart
Replies: 6
Views: 1366

Re: Problems usin SW Chanel of CAL Uart

But the question is, is there any way to get the right timing? And whats the reason for the difference?
by CSM2711
Fri May 10, 2019 11:12 am
Forum: Flowcode V8
Topic: Problems usin SW Chanel of CAL Uart
Replies: 6
Views: 1366

Re: Problems usin SW Chanel of CAL Uart

you are absolutly right, it seems to be a problem with the timing.
But why?
by CSM2711
Fri May 10, 2019 10:32 am
Forum: Flowcode V8
Topic: Problems usin SW Chanel of CAL Uart
Replies: 6
Views: 1366

Re: Problems usin SW Chanel of CAL Uart

ok , i have tes with a small testprogramm, it looks like something is wrong with the timitng ......
i will try to measure it.....
by CSM2711
Fri May 10, 2019 8:46 am
Forum: Flowcode V8
Topic: Problems usin SW Chanel of CAL Uart
Replies: 6
Views: 1366

Problems usin SW Chanel of CAL Uart

Hello,

I have some problem by using the Software chanel of CAL Uart on my PIC16F1827.
When I use the Hardware chanel everthing works fine, after selecting sofware chanel (same Pins) the uart want work.
Does everyone has an Idea?
by CSM2711
Fri Mar 29, 2019 10:56 am
Forum: Flowcode V8
Topic: 16LF18857
Replies: 9
Views: 2247

Re: 16LF18857

I think you should use a output component (LED) to visualize the Programm and configure the Port pins.
by CSM2711
Tue Mar 19, 2019 8:02 am
Forum: Flowcode V8
Topic: ILI9341 SPI wont work
Replies: 2
Views: 1099

Re: ILI9341 SPI wont work

OK, i found the Problem.
The supply voltage was higher then 3V ......
But the display is very very slow, I try to colorize the background by draw a rectangle with red background color but it will take along time ......
Has someone an Idea or is that normal for this type of display?
by CSM2711
Wed Mar 13, 2019 1:39 pm
Forum: Flowcode V8
Topic: Problem using GLCD_SH1106_SPI
Replies: 4
Views: 1326

Re: Problem using GLCD_SH1106_SPI

I have found the problem, one IO-PIN (the D/C Pin) from my PIC was defective.......
by CSM2711
Wed Feb 27, 2019 2:25 pm
Forum: Flowcode V8
Topic: Problem using GLCD_SH1106_SPI
Replies: 4
Views: 1326

Re: Problem using GLCD_SH1106_SPI

yeah no it will work work...... almost.
The code will be compiled an prograammed, but the display shows not the expexted lines......
Ithink it will be a problem with the cloch frequency ....
Maybe someone has an Idea.
by CSM2711
Wed Feb 27, 2019 12:01 pm
Forum: Flowcode V8
Topic: ILI9341 SPI wont work
Replies: 2
Views: 1099

ILI9341 SPI wont work

Hello,

next display next Problem.....
I try to communicate wit a ILI9341 by use a PIC16F1827 but it wont work...
The only the backlight of the tft will light up :lol:
Maby someone can say me whats my mistake ?!?
by CSM2711
Wed Feb 27, 2019 11:38 am
Forum: Flowcode V8
Topic: Problem using GLCD_SH1106_SPI
Replies: 4
Views: 1326

Re: Problem using GLCD_SH1106_SPI

ok, Iwill try another Pic ....
by CSM2711
Wed Feb 27, 2019 7:50 am
Forum: Flowcode V8
Topic: Problem using GLCD_SH1106_SPI
Replies: 4
Views: 1326

Problem using GLCD_SH1106_SPI

Hello, i have a problem using the GLCD component. after call the device macro "initalize" the compiler will show the following massage "analog_to_display2.c: 214: (1250) could not find space (128 bytes) for variable _FCV_0ef51_gLCD_SH1106_SPI1__DRAM0" I have tested wit a PIC16F1827 and a PIC16F18325...
by CSM2711
Fri Feb 15, 2019 10:12 am
Forum: Flowcode V8
Topic: Problems using DAC Componentn PIC16F18313
Replies: 1
Views: 671

Problems using DAC Componentn PIC16F18313

Hello,

I have a Problem using the DAC Component with the PIC 16F18313.
I get always the Message " _FC_CAL_DAC_SetOutput_1(Flowcode1.obj) _FC_CAL_DAC_Enable_1(Flowcode1.obj) "
Maybe there is a Bug?
by CSM2711
Fri Feb 15, 2019 9:59 am
Forum: Programming Tips & Tricks
Topic: Component Creation
Replies: 10
Views: 6925

Re: Component Creation

Great Toturial!
But i have one Problem, I find my user component by search but i have no icon "User".
See attached picture
by CSM2711
Fri Feb 15, 2019 9:34 am
Forum: Flowcode V8
Topic: STM8 range micros
Replies: 8
Views: 1500

Re: STM8 range micros

oh yes!!!
the STM8 controllers are realy interesting!
by CSM2711
Thu Feb 14, 2019 3:51 pm
Forum: User Components
Topic: calculation only on simulation
Replies: 3
Views: 2064

Re: calculation only on simulation

Many Thanks !!!!
by CSM2711
Thu Feb 14, 2019 1:53 pm
Forum: User Components
Topic: calculation only on simulation
Replies: 3
Views: 2064

calculation only on simulation

Hello, i try to create a component for using the internal temperature indicator. So i add a scale from -40 to 85. Inspilulation the value schoeld be multiplied with 22 but only in the simulation.... I try to realize this bay use the simultion Symbol but it wont work... The value in the application (...
by CSM2711
Fri Jan 11, 2019 8:14 am
Forum: Bug Reports
Topic: wrong DAC PIN PIC16F1827
Replies: 1
Views: 909

wrong DAC PIN PIC16F1827

Hello everybody,

I tried today the DAC component to use, unfortunately in the properties of the component Channel1 PIN A0 (this can not be changed) will be displayed.
According to the data sheet, however, the DAC output is at PIN A2.
Can it be that something is wrong here?
by CSM2711
Thu Dec 06, 2018 11:11 am
Forum: Flowcode V8
Topic: Problems with ADC read out PIC16F18313
Replies: 10
Views: 2450

Re: Problems with ADC read out PIC16F18313

Hello,

actually i have again Problems with the ADC , specialy input A4.
I change the Test prgram by adding a Uart for debug.
The Programm will work fine in simulation, but when I make a Hardware setup the ADC value will always be 255.
Has anyone an Idea ?
by CSM2711
Wed Dec 05, 2018 11:05 am
Forum: Flowcode V8
Topic: help using sleep mode
Replies: 1
Views: 927

Re: help using sleep mode

ok i found the mistake.
You mus set syncronisation to "not synchronised"
timer0.JPG
timer0.JPG (31.22 KiB) Viewed 923 times
by CSM2711
Wed Dec 05, 2018 10:51 am
Forum: Flowcode V8
Topic: help using sleep mode
Replies: 1
Views: 927

help using sleep mode

I moment I try to use the sleep mode of the PIC16F18313, unfortunately I have the following problem: the Sleep mode works fine until I activate the Timer0. Unfortunately I do not understand why sleep mode does not work when Timer0 is enabled. Does anyone have an idea? sleep.JPG Thank you in advance.
by CSM2711
Fri Nov 30, 2018 10:27 am
Forum: Flowcode V8
Topic: Compiler Error using RS232
Replies: 5
Views: 1615

Re: Compiler Error using RS232

Am I really the only one who has this problem?
Or is there only this problem with the PIC16F18313?