Search found 62 matches

by dannyvanneijenhoff
Wed Apr 15, 2020 2:29 pm
Forum: Bug Reports
Topic: Bad mistake in FC8!
Replies: 48
Views: 7059

Re: Bad mistake in FC8!

i am not sure wich version it was (sorry :-) )

It was strange, because it has work for a few weeks on the laptop. And after i updated all the files (when i saw an updated ADC component), it wo'nt start up again.
by dannyvanneijenhoff
Wed Apr 15, 2020 9:19 am
Forum: Bug Reports
Topic: Bad mistake in FC8!
Replies: 48
Views: 7059

Re: Bad mistake in FC8!

Just had last week again the same problem (again) at my w10 pc, and on a w10home-1909 laptop msi i7-8750h after updating all the components (there was an new ADC component) in FC8.22... No other antivirus installed (yet :oops: ) other than microsoft. removed FC8 and reinstall after use Regedit to de...
by dannyvanneijenhoff
Tue Feb 25, 2020 10:47 pm
Forum: Flowcode V8
Topic: ADC problems with 18F87K22
Replies: 8
Views: 1186

Re: ADC problems with 18F87K22

Thanks :-) It works now the same as in FC4, after i have updated the ADC in FC. It starts at at 255 (0V on the adc input), than from zero (+/- 0,2V) to + 230 (4,6V). And that on 5 x ADC input. I have that also seen that in FC4 and made an work around in the hard an software. Not sure of that is an s...
by dannyvanneijenhoff
Sun Feb 23, 2020 10:12 pm
Forum: Flowcode V8
Topic: ADC problems with 18F87K22
Replies: 8
Views: 1186

Re: ADC problems with 18F87K22

Thanks, i will have added an 1 second flash/beep test at c2 (piezo on the pcb) PWM and B output is send as an output on the pcb, and working. I can read there any 8-bit ADC value. :D Now PortB and PWM flash random from 0 to 255 :?: Green led and lightbulb is the PWM, red led's are output B on the pc...
by dannyvanneijenhoff
Sun Feb 23, 2020 8:33 pm
Forum: Flowcode V8
Topic: ADC problems with 18F87K22
Replies: 8
Views: 1186

Re: ADC problems with 18F87K22

I did make an new programm with 2x ADC and new settings's. And upoaded the new FCFX

Unfortonaly, still not working :cry:
by dannyvanneijenhoff
Sat Feb 22, 2020 7:42 pm
Forum: Flowcode V8
Topic: ADC problems with 18F87K22
Replies: 8
Views: 1186

Re: ADC problems with 18F87K22

Thanks for your reply :-)

I see, but i also tested it with "GetByte"
I forget to put it back from rawsample to "GetByte" :oops:
Should i also start with an fresh and clean programm ? It looks like, i removed all the old data from this one.
by dannyvanneijenhoff
Sat Feb 22, 2020 1:24 pm
Forum: Flowcode V8
Topic: ADC problems with 18F87K22
Replies: 8
Views: 1186

ADC problems with 18F87K22

Hello Can someone please look at the setting's, and the configure options. :) Everything is working with FC8, except i cann't get the ADC's working with FC7 and FC8. :? The hardware works fine with the old FC4 programm. We did not upgrade the software from FC4 to FC6 in the past, because of the same...
by dannyvanneijenhoff
Thu Feb 20, 2020 11:18 pm
Forum: Fixed bugs
Topic: PIC18F87K22 RC0 - RC1 not work ! [Solved]
Replies: 5
Views: 4833

Re: PIC18F87K22 RC0 - RC1 not work ! [Solved]

here is another setting for PWM on C1
c1.png
(4.8 KiB) Downloaded 1366 times
by dannyvanneijenhoff
Wed Nov 27, 2019 9:03 am
Forum: Flowcode V8
Topic: LEDs and LED Array not simulating correctly 8.2.1.13
Replies: 9
Views: 6389

Re: LEDs and LED Array not simulating correctly 8.2.1.13

Could also not open an new project. Did remove the "old" FC8, i am not sure which version i was using. I did use Help, Check for updates in help 2 times. And did an reinstal of 8.2, and now everything is working, including the LED's in the 2d dashboard panel :) But like Martin said, this is the path...
by dannyvanneijenhoff
Mon Nov 25, 2019 3:54 pm
Forum: Flowcode V8
Topic: LEDs and LED Array not simulating correctly 8.2.1.13
Replies: 9
Views: 6389

Re: LEDs and LED Array not simulating correctly 8.2.1.13

Hello

After this "update".
I get 2 errors with starting the programm, and choosing another micro is not possible.
power up.JPG
power up.JPG (10.99 KiB) Viewed 5214 times
speed.JPG
speed.JPG (15.63 KiB) Viewed 5214 times
I have an pro version

Thanks
BR Danny
by dannyvanneijenhoff
Fri May 24, 2019 10:52 am
Forum: Flowcode V8
Topic: e3 input on 16F18857
Replies: 1
Views: 674

e3 input on 16F18857

Hello When i use e3 as input. And when generating code, the compiler give an error. When i remove input e3, the program is working on hardware On FC 6 and 7 no problem. FC8 test 16f18857 rev0.c: main() 84: FCV_TEST_E3 = (FC_CAL_Port_In_DDR__x((&PORTE), (&TRISE), ((1<<3)), (3))); (192) undefined iden...
by dannyvanneijenhoff
Fri Mar 23, 2018 10:01 am
Forum: Flowcode V7
Topic: 16f18313 not support?
Replies: 7
Views: 2819

Re: 16f18313 not support?

Thanks, There was different information :-( TABLE 1-2: PIC16(L)F18313 PINOUT DESCRIPTION RA3 /MCLR/VPP TTL/ST CMOS General purpose I/O. And on other places: • Up to 12 I/O Pins: (but 1 = input) The MCLR pin provides three specific device functions: • Device Reset (when MCLRE = 1) • Digital input pin...
by dannyvanneijenhoff
Thu Mar 22, 2018 7:10 pm
Forum: Flowcode V7
Topic: 16f18313 not support?
Replies: 7
Views: 2819

Re: 16f18313 not support?

I have problems with RA3: (for Pic16F18323) R-pull Up is working (on and off) MCLR is now off (after set low voltage proramming OFF) Input works also But no OUTPUT on RA3 In the PDF of the micro stands: RA3 /MCLR/VPP RA3 TTL/ST CMOS General purpose I/O. MCLR TTL/ST — Master Clear with internal pull-...
by dannyvanneijenhoff
Thu Mar 22, 2018 10:59 am
Forum: Flowcode V7
Topic: 16f18313 not support?
Replies: 7
Views: 2819

Re: 16f18313 not support?

New micro, more functions :oops:
Knipsel.JPG
Knipsel.JPG (21.26 KiB) Viewed 2631 times

Thanks
by dannyvanneijenhoff
Mon Mar 19, 2018 5:40 pm
Forum: Flowcode V7
Topic: 16f18313 not support?
Replies: 7
Views: 2819

Re: 16f18313 not support?

Hello

For this pic, i can not find the INTERNAL CLOCK Source Types . Also for Pic16F18323
81b6a700-33f0-4379-8c5d-93cf7ed01951.jpg
81b6a700-33f0-4379-8c5d-93cf7ed01951.jpg (80.75 KiB) Viewed 2654 times
by dannyvanneijenhoff
Sun May 28, 2017 7:42 pm
Forum: Flowcode V7
Topic: PIC as MODBUS slave
Replies: 80
Views: 47763

Re: PIC AS MODBUS SLAVE

done, and also updated my profile (a little bit late :oops:
by dannyvanneijenhoff
Mon May 22, 2017 5:07 pm
Forum: Flowcode V7
Topic: PIC as MODBUS slave
Replies: 80
Views: 47763

Re: PIC AS MODBUS SLAVE

Thanks, i will check this next week I prefer when I check waveform problems or data with scope and hardware, programming is "new" for me :-) Perhaps send your data with PC and USB/485 dongle, and a cheap 485 modbus slave (which i have enough in stock) for testing. So that you have an working hardwar...
by dannyvanneijenhoff
Sun May 07, 2017 11:34 am
Forum: Flowcode V7
Topic: PIC as MODBUS slave
Replies: 80
Views: 47763

Re: PIC AS MODBUS SLAVE

I have the master working with an 16F887 with write single coils (not multiple coils). And the slave is responding correct. But i have no working reading from the data which are received from the slave. Perhaps we help each other. :mrgreen: I have attached the program and added the links. If i have ...
by dannyvanneijenhoff
Sun May 07, 2017 11:32 am
Forum: Flowcode V7
Topic: PIC as MODBUS slave
Replies: 80
Views: 47763

Re: PIC AS MODBUS SLAVE

Hello Benj

This link is not working/correct:
I would advise you to look at the example here to help get you started.
https://www.matrixtsl.com/wikiv7/index. ... ms:_System
by dannyvanneijenhoff
Thu May 04, 2017 9:12 am
Forum: Flowcode V7
Topic: Modbus Slave no CheckForIncoming
Replies: 3
Views: 2380

Re: Modbus Slave no CheckForIncoming

testing with same hardware with the master component:
I can assume that the hardware is working, as the pic send data and get data return.

BUT i get CRC fail 255 (pwm = 800)

I hope when i get to read the (working) master, i can test (and understand) the slave better.

Thanks for your help.
by dannyvanneijenhoff
Wed May 03, 2017 9:36 am
Forum: Flowcode V7
Topic: Modbus Slave no CheckForIncoming
Replies: 3
Views: 2380

Re: Modbus Slave no CheckForIncoming

Hello benj hardware setup: an working HMI (exor) with 485 modbus master connection to an ADAM modbus reciever, with 8 inputs and 8 outputs. Cable is 2mtr with start and end 120R. This system works 100% good (for months). Our PCB with 8mhz chrystal with FC7, has an working MASTER connection to the AD...
by dannyvanneijenhoff
Sun Apr 30, 2017 10:50 am
Forum: Flowcode V7
Topic: Modbus Slave no CheckForIncoming
Replies: 3
Views: 2380

Modbus Slave no CheckForIncoming

Hello I have no respons from the modbus slave with the Check For Incoming component. Maybe i have an wrong settings. I see on the scope the correct data signals from the output of the 485 IC, and the data direction pin is low, but no reaction :-( The hardware is working with an modbus master compone...
by dannyvanneijenhoff
Sat Apr 29, 2017 9:06 am
Forum: Flowcode V7
Topic: Modbus array of values input
Replies: 2
Views: 2390

Re: Modbus array of values input

Thanks for the reply, i can fill in the VAR "array" now ( not array[2] ) in the component but the data output is not correct, i am missing the data from VAR "array" wrong data : 2 15 0 0 0 8 0 .. 63 255 (from flowcode) correct data: 2 15 0 0 0 8 0 7 127 84 the VAR array[2] var is working in another ...
by dannyvanneijenhoff
Mon Mar 06, 2017 4:55 pm
Forum: Flowcode V7
Topic: Modbus array of values input
Replies: 2
Views: 2390

Modbus array of values input

Hello

I have trouble to use the field CoilData in "Force mutilpe coils" in modbus master, type BYTE[]

Nothing (sofar) is working, maybe something easy :shock:
Knipsel.JPG
Knipsel.JPG (21.3 KiB) Viewed 2390 times
by dannyvanneijenhoff
Tue Feb 28, 2017 10:40 pm
Forum: Flowcode V7
Topic: Losing Menu Bar
Replies: 4
Views: 3142

Re: losing manu MENU BAR Buttons

Losing MENU BAR, menu buttons, ... I had the same problem in FC 7.1.1.0, but this easy solution works fine. :D I was playing with the "bars", and suddenly, the menu bar was missing. And only visible when opens FC7, and disappear when i open an file. It cost me only some time, to find this solution. ...