Search found 115 matches

by chevy6600
Tue Nov 08, 2011 8:40 pm
Forum: General Programming
Topic: trying to update to 4.5?
Replies: 1
Views: 919

trying to update to 4.5?

Hi, it has been a long time since i was here, so i am finding this forum a bit different. This area seems as though it is the only area i can post in so if it not the correct area i`m sorry...i`ts because i can`t post any where else. My problem is that i have tried to update my flowcode prof v4.2.3....
by chevy6600
Tue Oct 27, 2009 9:49 am
Forum: Bugs / Application Errors
Topic: error code trying to `compile to hex`
Replies: 3
Views: 3493

Re: error code trying to `compile to hex`

Thanks for that Benj , it works now. :mrgreen: But i have installed ppp v3 Twice in the same directory, but i can only see one instance, if i tried to uninstall them, it would uninstall only one! the ppp v3 would still be there! My concern is that i have 2 lots of ppp v3 in the registry and may cau...
by chevy6600
Mon Oct 26, 2009 7:35 pm
Forum: Bugs / Application Errors
Topic: error code trying to `compile to hex`
Replies: 3
Views: 3493

error code trying to `compile to hex`

Hi all , i am having trouble to get flowcode v3 to `compile hex` it returns an error message ..... Error: Failed to open:libc.pic16.lib or C:\Program Files\SourceBoost\lib/libc.pic16.lib failure Return code = -2 i have got flowcode v4 and v3 installed on my pc, but in their own directories. It look...
by chevy6600
Tue May 26, 2009 8:00 pm
Forum: Flowcode V2 & V3
Topic: Reading RC imput
Replies: 4
Views: 2072

Re: Reading RC imput

Hi all, it`s been a while since i last browsed here, too busy doing other things that need doing instead of flowcoding. :cry: i`m on holiday at the mo and had time to see what all of you have been doing . FLINT 3058 did a little program which you may like to have a look at, http://www.matrixmultimed...
by chevy6600
Sun Feb 08, 2009 9:12 pm
Forum: Flowcode V2 & V3
Topic: Idependant flash rates needed
Replies: 3
Views: 1605

Re: Idependant flash rates needed

Hi timo , this might sound a bit obvious but maybe you missed this. As the program only does one instruction at a time, and you are using your adc to cause a delay....a delay as in halting the program in it`s tracks....the rest of the program will also be delayed until the delay ends which then all...
by chevy6600
Sun Feb 08, 2009 8:28 pm
Forum: General / Misc
Topic: flowcode Help
Replies: 12
Views: 6114

Re: flowcode Help

Hi steve22, you ought to have a list of demo programs in your instalation of flowcode but you need to go through them one at a time as they are listed with a number. I have attached one of these demo files here, this one uses a switch to cycle through a number of leds , these leds represent an incre...
by chevy6600
Thu Jan 29, 2009 10:08 pm
Forum: Flowcode V2 & V3
Topic: PIC analogue output
Replies: 2
Views: 1570

Re: PIC analogue output

Hi echase, you may find this info of some interest, i found it on the internet a while ago, it shows the different
methods DAC can be done along with the pro`s and cons.
http://www.faqs.org/docs/electric/Digital/DIGI_13.html
by chevy6600
Thu Jan 22, 2009 4:51 pm
Forum: General / Misc
Topic: pic chip freezes on startup
Replies: 6
Views: 2566

Re: pic chip freezes on startup

Hi all , just like to add that i have sorted the problem i had :mrgreen: , it was an integer variable that was not first initialised at the beginning of the program...i guess it was erratically first starting up with a negative number and having to work up to the `0` figure. Might be of something t...
by chevy6600
Thu Jan 22, 2009 10:42 am
Forum: Flowcode V2 & V3
Topic: PWM input?
Replies: 12
Views: 3919

Re: PWM input?

Hi flint, i have just had a look at the great little program of yours that you sent me via `pm post`. Although i have no hardware to try it out on it is the sort of program that i would use so i have added it to my ` program toolbox `and even better, you have managed it without using `c` code. Well...
by chevy6600
Wed Jan 21, 2009 11:45 pm
Forum: General / Misc
Topic: pic chip freezes on startup
Replies: 6
Views: 2566

Re: pic chip freezes on startup

Hi walkover , thanks for the tips. I have a voltage divider setup using a 1k potentiometer to get a spread of 0v - 5v, this then supplies the ADC. I am supplying the servo from a separate battery. Yes i have the 100nf capacitor in place....with other capacitors as well. I can get a small test progr...
by chevy6600
Tue Jan 20, 2009 10:28 am
Forum: General / Misc
Topic: pic chip freezes on startup
Replies: 6
Views: 2566

Re: pic chip freezes on startup

Hi benj, i am using 18F2620 and have ADC inputs on RA1 & RA2 , vref-, and vref+, outputs are on RC port.
by chevy6600
Tue Jan 20, 2009 9:08 am
Forum: General / Misc
Topic: pic chip freezes on startup
Replies: 6
Views: 2566

pic chip freezes on startup

Hi guys , can you please help with this problem?. I have got my pwm servo program to read 2 voltage inputs via ADC, the program generates PWM signal then the program adjusts PWM signal depending on the outcome of the ADC. Well, when i first start up the processor....ie. the actual hardware.....i ca...
by chevy6600
Mon Jan 19, 2009 4:58 pm
Forum: Flowcode V2 & V3
Topic: Using modulus
Replies: 3
Views: 1351

Re: Using modulus

Hi ondra, i thought i would go one better than my last post. i have put a demo simple maths routine together, dowload the program `mod` and just run it so that you can see flowcode variables.
by chevy6600
Mon Jan 19, 2009 4:19 pm
Forum: Flowcode V2 & V3
Topic: Using modulus
Replies: 3
Views: 1351

Re: Using modulus

Hi ondra, i used it in my servo program , this is what i used :

servo_val = ( servo_pos[port_counter] )
servo_l = ( servo_val MOD 3 ) * 85
servo_h = 31 + ( servo_val / 3 )
by chevy6600
Mon Jan 19, 2009 11:50 am
Forum: Flowcode V2 & V3
Topic: PWM input?
Replies: 12
Views: 3919

Re: PWM input?

Hi flint, I have a couple of thoughts that you may be interested in. You mentioned you had a 10mhz oscilloscope, assuming this means you are able to read 10mhz signal and not got a max bandwidth of 10mhz ie. You need an oscilloscope rated 20 - 30mhz bandwidth, some say you will need a bandwidth 10 ...
by chevy6600
Sun Jan 18, 2009 12:12 pm
Forum: Flowcode V2 & V3
Topic: PWM input?
Replies: 12
Views: 3919

Re: PWM input?

Hi flint, Just one other point i would like to mention. As it is inevitable that you will end up using `C` code within flowcode, this renders the flowcode debugger pretty much unusable as the debugger does not read `C` code. So while your pondering about how to tackle your project, i would also have...
by chevy6600
Sat Jan 17, 2009 8:21 pm
Forum: Flowcode V2 & V3
Topic: PWM input?
Replies: 12
Views: 3919

Re: PWM input?

Hi flint , i`ll start off saying that i am no expert at this programing lark, but if i can help i will. I started using flowcode about this time last year. Great program to play with. A couple of questions. What kind of pic are you looking to use :?: . Are you using any of the matrix development bo...
by chevy6600
Sat Jan 17, 2009 11:55 am
Forum: Flowcode V2 & V3
Topic: PWM input?
Replies: 12
Views: 3919

Re: PWM input?

Hi Flint3058 , seems we are both travelling the same path, i too am a Rc hobbyist, wanting to program my own controller, i have not come across any others in this field here in the forum....either they don`t post or don`t exist here.....it is a pretty quite forum on members chipping in....a bit dif...
by chevy6600
Fri Jan 16, 2009 9:40 pm
Forum: Flowcode V2 & V3
Topic: Book On Flowcode Released
Replies: 3
Views: 2628

Re: Book On Flowcode Released

WHOOO WEEE, i`ve place my order for one. :mrgreen:
........my birthday coming up........the wife can give it to me...i`ll just give her the bill. :mrgreen:
by chevy6600
Fri Jan 16, 2009 9:29 pm
Forum: Flowcode V2 & V3
Topic: glitch on PWM for servo signal
Replies: 15
Views: 4705

Re: glitch on PWM for servo signal

HI benj, To start off, i have found an extra ` output macro ` some where in my program, i thought it was deactivated by using the `mask` and unticking all bits, so now i have deleted this in case it made a difference...... Strangely it did :!: I have now re run the various variations using the ` ou...
by chevy6600
Fri Jan 16, 2009 3:12 pm
Forum: Flowcode V2 & V3
Topic: glitch on PWM for servo signal
Replies: 15
Views: 4705

Re: glitch on PWM for servo signal

Hi benj, i have been trying out the code but initially it did not make any difference but it is work in progress as other parts of the program need to be altered / removed which may be giving me the glitch, so i will need the week end to fully test out all variations before a conclusion can be made...
by chevy6600
Wed Jan 14, 2009 11:11 am
Forum: Flowcode V2 & V3
Topic: glitch on PWM for servo signal
Replies: 15
Views: 4705

Re: glitch on PWM for servo signal

Hi benj, i have done a bit more digging, i have tried to clarify the program and my problem by changing the 5 pin outputs to use port `c` pin rc5, port `B` /0/1/2/4 , but NOT `B3` the ccp pin!.... This may be of interest if you think the ccp pins are involved. The purpose is to take the signal out ...
by chevy6600
Tue Jan 13, 2009 11:28 pm
Forum: Flowcode V2 & V3
Topic: glitch on PWM for servo signal
Replies: 15
Views: 4705

Re: glitch on PWM for servo signal

Hi benj , that`s a great find. I must say that does look a good bet. but i`m afraid this part is a bit over my head, but i`ll help any way you think i can. I have been playing around with my program, i have tried `setting` and `clearing` port bits with only `C` code that you gave, and placed them i...
by chevy6600
Tue Jan 13, 2009 9:38 am
Forum: Suggestions
Topic: backing up project files & alterations
Replies: 2
Views: 2633

Re: backing up project files & alterations

Oh darn it.. :|
Some how i thought that may be the case.
by chevy6600
Tue Jan 13, 2009 9:02 am
Forum: Bugs / Application Errors
Topic: Compile to chip error
Replies: 10
Views: 6400

Re: Compile to chip error

Hi icabjeff , i`m no expert but i was browsing through this forum as i have a problem in another thread that i`m hoping that someone will help with so i know what it`s like when your stuck and your left hoping that your problem will get sorted. Any way back to your problem, i believe what is happen...