Search found 127 matches

by Crenwick
Thu May 01, 2014 10:46 am
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

The command line I use for test is "mloader -chip 16F887 test.hex" About the 7805 a Vin of 7.8V is fine as you have a Vdrop of 2V over the regulator. I tested this with a load of 500mA without problem (Vout = stable 5V) The only "known" problem of the 7805 is that he's getting hot due to this 2V dro...
by Crenwick
Tue Apr 29, 2014 4:11 pm
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

I'm using a 9V PSU for the reason I explain above (bridge rectifier drops 1.2V) and 7805 became unstable when PSU at 7.5V input.

This will not make a difference I think because L1 is connected to VCC (5V) from the 7805. Maybe connect L1 to Vregin ?
by Crenwick
Tue Apr 29, 2014 3:38 pm
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

I'm now checking the noise on the power lines and checking why this noise goes up when programming. After analyzing the Charge Pump Circuitry I have some questions (sorry for this :oops: ) 1- Do you know that when the CPC is idle there is a voltage of 37V over C18 ? 2- Shouldn't be better to add a r...
by Crenwick
Tue Apr 29, 2014 2:13 pm
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Ooops ! I was little bit to fast :oops:

Another thing I saw is that PPP_PGD_O on the side of R92 was sometimes "dirty" at low level. Didn't had time to check the output properties of RA1/RPI17.

Sorry,
by Crenwick
Tue Apr 29, 2014 11:50 am
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Hi Ben, Just has a look at the chip U4 on the board (4053), is it not better to ground non used inputs (Z0/Z1/C) Can you explain why divide PROGABC by 2 with R8/16 ? What's the utility of U4 (switching CLK/DATA to 40p Header ???) Regards, [EDIT] Ben, I think I found a problem ! I checked the input/o...
by Crenwick
Tue Apr 29, 2014 9:46 am
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Here I am again ! Well this morning I rolled my eyes when I used my ZIF interface with a 16F1937. Mloader doesn't recognize anymore the 16F1937 :roll: . So I tested a 16F887 with ZIF and YES it's working !!! For information when 16F1937 directly on socket of EB006 then ok. I began to scratch my head...
by Crenwick
Mon Apr 28, 2014 4:58 pm
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

bobingabout wrote:This should be the same program for the 1937, I get the same problems that I get with the 84A.
Your file is ok on my board
test.jpg
test.jpg (68.66 KiB) Viewed 10163 times
What I saw is that the error "Unknown chip type in data file" also appears when there is no PIC on board, it's like the board doesn't see the PIC !
by Crenwick
Mon Apr 28, 2014 3:27 pm
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Hi all, I tested a simple Led blinker prog with all the PIC's I have here and only one didn't accept to program (fortunately I have two of them so I crosschecked) but has nothing to do with V9 because FC6 is also unable to program it with my V7 board ! What I tested 12F675 -- OK 16F88 -- OK 16F628 -...
by Crenwick
Mon Apr 28, 2014 1:32 pm
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

bobingabout wrote:I don't have any 88 or 628. I do have some 877, an 877A and 887, and some 883s, plus the 1937 that came with the EB006V9. That's my entire selection.

Also, those that you linked are the same versions of the files I'm already using.
887 and 1937 is also good for me :wink:
by Crenwick
Mon Apr 28, 2014 12:48 pm
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

One remark about the power supply ! I tested now the board in USB and Extenal Power mode. The power supply is the one supplied by Matrix and is adjustable (3/4.5/6/7.5/9/13.5V). When I tested my project (True RMS Voltage sensor with 16F887/EB005LCD/EB004LED/EB007SWITCHES+breadboard) I also followed ...
by Crenwick
Mon Apr 28, 2014 11:00 am
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Hi, Sorry I have no more 16F84A in house. Can you recompile for 16F88 or 16F628 then I can test your HEX. The driver I used for V9 is http://www.matrixmultimedia.com/resources/getresource.php?id=744 And the mloader is the one loaded with FC6.0.7 but also tested with http://www.matrixmultimedia.com/r...
by Crenwick
Mon Apr 28, 2014 5:24 am
Forum: E-blocks
Topic: Lem HTFS 200-p Sensor
Replies: 5
Views: 4625

Re: Lem HTFS 200-p Sensor

Hi Steve,

Just a question, why are you passing two times the cable through the sensor ? I'm using a clip sensor and need only one pass.

Regards,
by Crenwick
Sun Apr 27, 2014 10:43 am
Forum: User Components
Topic: Component Creation Tutorials
Replies: 6
Views: 6243

Re: Component Creation Tutorials

Hi Jordy,

Thanks for the great job ! I have now some basements to start creating components :)

Personally I find that Matrix doesn't give enough documentation about this stuff and it's counter productive.

Come on Matrix :wink:

Regards,
by Crenwick
Sat Apr 26, 2014 8:09 pm
Forum: User Components
Topic: DS3231 - RTC Time Keeper
Replies: 64
Views: 36091

Re: DS3231 - RTC Time Keeper

Hi Jordy,

Many thanks for your work !

I have a question about 12/24h setting. In the DS1307 component we have the HoursFormat variable in WriteTime but I'm unable to to find this item in the DS3231 component.

Is there another trick to change this setting :wink:

Regards,
by Crenwick
Sat Apr 26, 2014 11:05 am
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Hi all, I'm not sure of this statement but today it started working when I used Matrix power supply switched to 9V. First times I set it to 7.5V power and also to USB power. Is it possible that the V9 board turns unstable when not powered enough ? I'm working this weekend on two projects so I will f...
by Crenwick
Thu Apr 24, 2014 8:29 pm
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Deleted ...
by Crenwick
Thu Apr 24, 2014 2:32 pm
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Mine is installed with Matrix driver and the board is connected directly to mainboard without hub.

I will check when I'm back at home if WinUsb devicedriver is also installed.
by Crenwick
Thu Apr 24, 2014 2:02 pm
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Hello, The board is working great here on my Windows 7 64-bit setup and in fact on every machine in the building but I have reports that on some systems the Windows Update driver is overpowering our driver every time the computer is connected back to the internet. If you have the EB006 v9 hardware ...
by Crenwick
Thu Apr 24, 2014 9:37 am
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Hi Ben,

Nice to have some feedback :)

Do you plan to use an alternative to winusb ?

Regards,
by Crenwick
Thu Apr 24, 2014 7:55 am
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Hi all,

Thanks for the feedback, I will try to contact the staff.
by Crenwick
Wed Apr 23, 2014 9:43 pm
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Hi Jac,

Well like you can see I have a lot of HID interfaces.
HID.jpg
HID.jpg (80.84 KiB) Viewed 9618 times
I'm only using one mouse and one keyboard from Logitech .

What do you think ?

Regards,
by Crenwick
Wed Apr 23, 2014 7:57 pm
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Hello, I tried something today, I programmed a 16F1937 with a simple 500ms blink led on RB0 with my EB006-V7 board. Then I switched from board to the V9 and tested the ICT function and it works ! ICT.jpg So I suppose my V9 board should be ok ? I'm more and more convinced that the problem comes from ...
by Crenwick
Tue Apr 22, 2014 12:12 pm
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Hi all,

Worked some hours this weekend without success on V9 board :(

Who is working at Matrix on Mloader ?

Is Mloader and V9 board working without any problems on your systems ?

Regards,
by Crenwick
Fri Apr 18, 2014 1:19 pm
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Bad news ! :( I had to restart my desktop for windows updates and now my V9 doesn't work anymore ... It's really disappointing , I tried five times to uninstall/install the driver without success, even on my laptop it stopped working. More and more I think that the on-board PIC24 is doing strange th...
by Crenwick
Fri Apr 18, 2014 7:17 am
Forum: E-blocks
Topic: EB-006-00-9 Driver issue
Replies: 116
Views: 60004

Re: EB-006-00-9 Driver issue

Good Morning ! This morning as test purpose I did the following : 1. Test my V9 board --- ok :) 2. Install again the V7 driver and retest V9 with mloader -- FAILED 3. Uninstall V7 driver and test V9 board -- FAILED but with a "Unknown chip type in datafile" 4. Uninstall and reinstall V9 driver with ...