Search found 153 matches

by Lagoda
Thu Feb 07, 2019 9:04 am
Forum: Bug Reports
Topic: Selecting a 2.048V reference voltage in PIC16F15324
Replies: 6
Views: 1295

Selecting a 2.048V reference voltage in PIC16F15324

Hi Ben, I would like to use the ADC module of PIC16F15324 MCU . The Vdd of the circuit is 3.3V. I set the reference voltage source to the FVR on the AD Properties tab. I inserted the following line in C code: FVRCON = 0x82; to select the 2.048V internal reference source. But is not working. Based on...
by Lagoda
Wed Dec 05, 2018 11:12 pm
Forum: 16-Bit PIC
Topic: PIC24 Internal CLocking
Replies: 5
Views: 2644

Re: PIC24 Internal CLocking

Hi Leo,

I think the System Clock speed of the processor can not be higher than 32MHz, because in the PLL system block has a divider, that always divided by 3 the clock signal from 96 MHz output.

Kind regards,

Lagoda
by Lagoda
Wed Dec 05, 2018 1:35 pm
Forum: Bug reports
Topic: Port mapping bug in the ICT module.
Replies: 5
Views: 2821

Re: Port mapping bug in the ICT module.

Thanks. I use the Flowcode 7 also. Would be repaired version for this?
by Lagoda
Sat Dec 01, 2018 2:33 pm
Forum: Bug reports
Topic: Port mapping bug in the ICT module.
Replies: 5
Views: 2821

Re: Port mapping bug in the ICT module.

Hello Leigh,

I bought Flowcode 8, but the problem is same as before. :roll: :cry: :cry:
Would you be so kind to fix it.

Lagoda
by Lagoda
Wed Feb 28, 2018 1:42 pm
Forum: 32-Bit PIC
Topic: A little cosmetic mistake. PIC32MZ (Solved)
Replies: 4
Views: 2608

Re: A little cosmetic mistake. PIC32MZ

Hi Ben,

Once you have a lot of time ... :)

I just wanted to report it, it does not cause any problems.

Thank you very much for the answer.

Best Regards,

Lagoda
by Lagoda
Wed Feb 28, 2018 12:31 pm
Forum: 32-Bit PIC
Topic: A little cosmetic mistake. PIC32MZ (Solved)
Replies: 4
Views: 2608

Re: A little cosmetic mistake. PIC32MZ

Hi Ben, I think this tag is more logical for 16-bit ports (H and L) than the PIC32 example. That's why I wrote a cosmetic mistake. PORTS.jpg If the ports of the PIC32 family are deliberately marked on this way, this is fine for me. But why do you use two types of marking within Flowcode? Best Regard...
by Lagoda
Mon Feb 26, 2018 10:12 pm
Forum: Bug reports
Topic: Port mapping bug in the ICT module.
Replies: 5
Views: 2821

Port mapping bug in the ICT module.

Hi Ben, I've written about this topic in the following post: http://www.matrixtsl.com/mmforums/viewtopic.php?f=2&t=19766 Unfortunately, it did not improve with 7.3.0.7 update, so I'll re-issue this problem. I would like to use ICT function of FlowKit2. In the Flowcode 7.3.0.5 or higher version, in t...
by Lagoda
Mon Feb 26, 2018 8:51 pm
Forum: 32-Bit PIC
Topic: A little cosmetic mistake. PIC32MZ (Solved)
Replies: 4
Views: 2608

A little cosmetic mistake. PIC32MZ (Solved)

Hello Ben,

I installed version 7.3.0.7 and after that I noticed this.
The names of the ports are incorrect.jpg
The names of the ports are incorrect.jpg (137 KiB) Viewed 2608 times
Best Regards,

Lagoda
by Lagoda
Mon Feb 26, 2018 5:59 pm
Forum: Bug reports
Topic: Bug in the Data Recorder (SOLVED:Use the Data Recorder in ICT mode)
Replies: 5
Views: 2153

Re: Bug in the Data Recorder

Hello Ben,

I understand the cause of the problem.
Thank you again for the answer.

Lagoda
by Lagoda
Mon Feb 26, 2018 4:21 pm
Forum: Bug reports
Topic: Bug in the Data Recorder (SOLVED:Use the Data Recorder in ICT mode)
Replies: 5
Views: 2153

Re: Bug in the Data Recorder

Hi Ben,

Thanks for the reply.

I'm sorry that the simulation does not provide a reliable result in this case.
For 100 us, 10us, and 1us delay, the pulse width measured on the RC0 pin is 0.53us according to the simulation.
Is this the same reason?

Best Regards,

Lagoda
by Lagoda
Sun Feb 25, 2018 2:52 pm
Forum: Bug reports
Topic: Bug in the Data Recorder (SOLVED:Use the Data Recorder in ICT mode)
Replies: 5
Views: 2153

Bug in the Data Recorder (SOLVED:Use the Data Recorder in ICT mode)

Hi Everyone,
I found this bug in Flowcode 7.3.0.6 during simulation.
I think the pictures say everything from the problem.

Best Regards,
Lagoda
by Lagoda
Wed Feb 14, 2018 3:58 pm
Forum: E-blocks
Topic: Flowkit 2 Debugging Speed [Solved]
Replies: 10
Views: 4939

Re: Flowkit 2 Debugging Speed [Solved]

OK! :)
Thank you very much.
by Lagoda
Wed Feb 14, 2018 10:19 am
Forum: E-blocks
Topic: Flowkit 2 Debugging Speed [Solved]
Replies: 10
Views: 4939

Re: Flowkit 2 Debugging Speed [Solved]

:(
by Lagoda
Sat Feb 10, 2018 10:48 pm
Forum: E-blocks
Topic: Flowkit 2 Debugging Speed [Solved]
Replies: 10
Views: 4939

Re: Flowkit 2 Debugging Speed [Solved]

Hello, Ben and Leigh, I tested my FlowKit2 on the weekend. Depending on the version of the Flowcode I found the differences. No matter what kind of operating system or hardware configuration I tried it on. The DIGITAL part of ICT functionality works well in Flowcode version 7.2.1.4. (Although I did ...
by Lagoda
Thu Feb 08, 2018 1:51 pm
Forum: E-blocks
Topic: Flowkit 2 Debugging Speed [Solved]
Replies: 10
Views: 4939

Re: Flowkit 2 Debugging Speed [Solved]

Hi Leigh, Thank you for quick responding to the problem. I tried to use FlowKit 2 on several machines, 1. on a laptop under WINDOWS 7 with Flowcode 7.3.0.6 + Patch 2. on a gamer machine under WINDOWS 10 under a newly installed Flowcode 7.3.0.6 + Patch 3. and a medium-sized desktop on WINDOWS 7 opera...
by Lagoda
Wed Feb 07, 2018 11:18 pm
Forum: E-blocks
Topic: Flowkit 2 Debugging Speed [Solved]
Replies: 10
Views: 4939

Re: Flowkit 2 Debugging Speed [Solved]

Hi QMESAR, Would you be so kind to tell me, What was the solution to the problem? I also have a FlowKit2 board since a year. So far it was in the desk drawer, I haven't used it. Now I want to debug with it , but the ICD module don't working. Every information interesting for me in this topic, becaus...
by Lagoda
Wed Dec 13, 2017 3:38 pm
Forum: 32-Bit PIC
Topic: PIC32MZ2048EFM144 UART Interrupt (SOLVED)
Replies: 4
Views: 2443

Re: PIC32MZ2048EFM144 UART Interrupt

:D Joy and happiness!!! :D

The improved version that you have created works perfectly.

The UART bridge now works in my circuitboard, but I do not know what it was. :o

Thanks again for your help.

Lagoda
by Lagoda
Wed Dec 13, 2017 12:45 pm
Forum: 32-Bit PIC
Topic: PIC32MZ2048EFM144 UART Interrupt (SOLVED)
Replies: 4
Views: 2443

Re: PIC32MZ2048EFM144 UART Interrupt

Hi Ben, Works well with the test program. :) I have created an UART bridge on the target panel between the GSM module and an RS232 interface with UART RX interrupt. Unfortunately, it does not work in this program. Maybe I did something wrong. I'll check it out. Thanks for the quick fix. I'll let you...
by Lagoda
Tue Dec 12, 2017 12:01 am
Forum: 32-Bit PIC
Topic: PIC32MZ2048EFM144 UART Interrupt (SOLVED)
Replies: 4
Views: 2443

PIC32MZ2048EFM144 UART Interrupt (SOLVED)

Hi Ben, Now there is a problem with UART interrupt. When a byte is loaded into RX FIFO it does not cause interrupt. I used the Configure setting, what Stefan Erni suggested. (Boot ISA Selection=Boot code and Exception code is MIPS32) I tried to debugging with different settings of SFR (priority leve...
by Lagoda
Thu Dec 07, 2017 1:48 pm
Forum: 32-Bit PIC
Topic: PIC32MZ2048EFM144 UART problem (incorrect remap pins) (SOLVED)
Replies: 6
Views: 3574

Re: PIC32MZ2048EFM144 UART problem (incorrect remap pins) (SOLVED)

Hi Ben,

Super! :D

I tried just a few pins, but they worked.

Thank you very much.

Lagoda
by Lagoda
Thu Dec 07, 2017 1:33 pm
Forum: 32-Bit PIC
Topic: PIC32MZ2048EFM144 Modbus Problem (Solved)
Replies: 2
Views: 2289

Re: PIC32MZ2048EFM144 Modbus Problem

Hi Ben,

Hurray! :D

The repaired version is works perfectly.

Thanks for your quick help.

Lagoda
by Lagoda
Wed Dec 06, 2017 8:33 pm
Forum: 32-Bit PIC
Topic: PIC32MZ2048EFM144 Modbus Problem (Solved)
Replies: 2
Views: 2289

PIC32MZ2048EFM144 Modbus Problem (Solved)

Hi Ben, Now there is a problem with the Modbus Master component. It would be good if you could help me. While the Modbus Master sending a data packet to the Slave, during the DIR-pin switch to receiving. On the RX pin also shows a 110ns long pulse, but I do not know why. (Probably due it is to switc...
by Lagoda
Mon Nov 27, 2017 4:12 pm
Forum: 32-Bit PIC
Topic: PIC32MZ2048EFM144 UART problem (incorrect remap pins) (SOLVED)
Replies: 6
Views: 3574

Re: PIC32MZ2048EFM144 UART problem

Hi Stefan,

Thank you very much for the informations.
The knowledge that you share will be useful to me as well.
I'm glad you work with this MCU family and there I'm not alone on the forum with the problems. :)

I'm begining of the work , now testing the peripherals.

Best Regards,
Lagoda
by Lagoda
Sun Nov 26, 2017 6:20 pm
Forum: 32-Bit PIC
Topic: PIC32MZ2048EFM144 UART problem (incorrect remap pins) (SOLVED)
Replies: 6
Views: 3574

Re: PIC32MZ2048EFM144 UART problem

:D I found the cause of the mistake! The Rx input of the UART6 I set in the Flowcode to the RD5 pin, but in fact the RB6 was activating. When I checked the content of the U6RXR register I found 0x05 instead of 0x06. I corrected the value to 0x06 in source C and then it worked. Unfortunately I do not...