Search found 14218 matches

by Benj
Mon Jun 29, 2020 11:51 am
Forum: Bug reports
Topic: SSD1322 macro crashes FC7 test
Replies: 43
Views: 4593

Re: SSD1322 macro crashes FC7 test

Hello,

I've sent you a PM.
by Benj
Mon Jun 29, 2020 10:48 am
Forum: Flowcode V8
Topic: Piezo Sounder accuracy
Replies: 16
Views: 780

Re: Piezo Sounder accuracy

Hi Ian, The piezo component is likely using a software loop which will generally always be a bit inaccurate. A way you could do it much more accuratley would be to use a timer interrupt to generate the output frequency. You could then use a second timer interrupt to monitor the passing of time and u...
by Benj
Mon Jun 29, 2020 10:44 am
Forum: Flowcode V7
Topic: ENC28J60 - Component
Replies: 4
Views: 302

Re: ENC28J60 - Component

Hi Steve, The ENC is fairly low level so I think this should be possible. However it might get fairly technical in terms of permissions etc. Definatley worth a go. I've also found there is a limit to how much data you can send in one chunk with this, seems limited to 256 bytes though this doesn't se...
by Benj
Fri Jun 26, 2020 3:19 pm
Forum: Bug Reports
Topic: Problem with latest update
Replies: 13
Views: 832

Re: Problem with latest update

Thanks Bruno, Think it's something I've done, looking into it now.
by Benj
Fri Jun 26, 2020 3:18 pm
Forum: Flowcode V8
Topic: Problems with update
Replies: 1
Views: 161

Re: Problems with update

Many thanks for lettig us know. We are aware of the issue and are looking into it.

Think it's something I've done :o .
by Benj
Wed Jun 24, 2020 12:05 pm
Forum: Flowcode V8
Topic: MULTIPLE UARTS PROBLEM
Replies: 3
Views: 362

Re: MULTIPLE UARTS PROBLEM

Hello,

With the latest updates you should be allowed up to 16, let me know if this isn't the case and I'll make sure this is on the update system. We have recently had a few issues moving to a new server and this may have been missed.
by Benj
Tue Jun 23, 2020 11:09 pm
Forum: Bug Reports
Topic: Modbus TCP slave invalid response
Replies: 12
Views: 881

Re: Modbus TCP slave invalid response

I've now made that change for you, thanks for letting us know.

Hopefully that will solve the problem but let us know how you get on.
by Benj
Tue Jun 23, 2020 10:58 pm
Forum: Bug Reports
Topic: Modbus TCP slave invalid response
Replies: 12
Views: 881

Re: Modbus TCP slave invalid response

Hi George,

Thanks that's a great find, I'll investigate for you and see if I can spot the problem.
by Benj
Tue Jun 23, 2020 10:16 am
Forum: Bug Reports
Topic: IR sensor error
Replies: 10
Views: 597

Re: IR sensor error

Fix should be available now using Help -> Check for updates.
by Benj
Tue Jun 23, 2020 10:15 am
Forum: Flowcode V8
Topic: PIC18F47Q10 ADC not working
Replies: 34
Views: 1931

Re: PIC18F47Q10 ADC not working

Should be available via the update system for you now.
by Benj
Tue Jun 23, 2020 9:56 am
Forum: Flowcode V5
Topic: Flowcode v5 for dsPIC registration issues .
Replies: 12
Views: 3090

Re: Flowcode v5 for dsPIC registration issues .

Thanks for letting us know, glad your up and running again :D
by Benj
Mon Jun 22, 2020 2:59 pm
Forum: General Programming
Topic: SuperCapacitor Backup supply
Replies: 13
Views: 7105

Re: SuperCapacitor Backup supply

Hi Steve,

Wow that's a decent amount of time to keep the MCU running for. How long does it take the cap to charge back up when powered on again?
by Benj
Mon Jun 22, 2020 2:57 pm
Forum: Flowcode V8
Topic: MPU6050
Replies: 26
Views: 2107

Re: MPU6050

Hello, If your using USB on the ECIO then when you reset it to program you will need to hold the reset button for at least a couple of seconds. This just gives the PC chance to see the USB disconnect before the bootloader reconnects. Hope this helps. Also reset the ECIO to make it pop up in device m...
by Benj
Mon Jun 22, 2020 2:54 pm
Forum: Programming Tips & Tricks
Topic: Connecting 2 to 9 switches on one ADC pin
Replies: 12
Views: 1191

Re: Connecting 2 to 9 switches on one ADC pin

Brilliant and easy to follow, thanks for sharing :D
by Benj
Mon Jun 22, 2020 2:44 pm
Forum: Flowcode V8
Topic: PIC18F47Q10 ADC not working
Replies: 34
Views: 1931

Re: PIC18F47Q10 ADC not working

Hello,

I'm running with the 64MHz INTOSC too so that shouldn't be causing any issues.

The attached should solve the ADC problems for you.
PIC_CAL_ADC.c
(148.92 KiB) Downloaded 35 times
Simply copy the file here.
C:\ProgramData\MatrixTSL\FlowcodeV8\CAL\PIC

I'll get both fixes pushed to the update system ASAP.
by Benj
Mon Jun 22, 2020 2:10 pm
Forum: Bug Reports
Topic: IR sensor error
Replies: 10
Views: 597

Re: IR sensor error

I've fixed the problem, just need to push it to the update system. Hopefully I'll be able to do this shortly.
by Benj
Mon Jun 22, 2020 10:03 am
Forum: Flowcode V8
Topic: .hex and .bin output files
Replies: 4
Views: 358

Re: .hex and .bin output files

Hello, We usually use .hex just because that's what the compiler often outputs. We also use bin files on some devices for the same reason. A .hex file has a checksum on every line. For a .bin file you would have to make your own checksum by running a mathematical process on each byte or pair of byte...
by Benj
Thu Jun 18, 2020 5:00 pm
Forum: Forums d'aide en français
Topic: Problème compilation FC5, erreur Compilation FCV5
Replies: 2
Views: 926

Re: Problème compilation FC5, erreur Compilation FCV5

Bonjour, Le problème pourrait-il être causé par unicode aucun caractère ASCII dans vos commentaires en haut de la page principale? Dans le programme v6, vérifiez que vos points de connexion sont correctement connectés. Hello, Could the problem be caused by unicode none ASCII characters in your comme...
by Benj
Thu Jun 18, 2020 4:00 pm
Forum: Flowcode V8
Topic: PIC18F47Q10 ADC not working
Replies: 34
Views: 1931

Re: PIC18F47Q10 ADC not working

Hello, PWM now working just trying to push the latest fix to the update system and there's still a few kinks were working on here. So for now you can use this file by copying it to this folder location "C:\ProgramData\MatrixTSL\FlowcodeV8\FCD\PIC" 18F47Q10.fcdx Copy the file and restart Flowcode and...
by Benj
Wed Jun 17, 2020 2:15 pm
Forum: Flowcode V8
Topic: PIC18F47Q10 ADC not working
Replies: 34
Views: 1931

Re: PIC18F47Q10 ADC not working

Ok thanks, I think I'll try and get a chip to play with. I'll have another go through the PWM code this afternoon to see if I can spot anything else. It's bound to be something really simple causing the problems. Edit, just bought one of these hopefully it will be here tomorrow. https://uk.farnell.c...
by Benj
Wed Jun 17, 2020 2:13 pm
Forum: Flowcode V8
Topic: ATECC508A INTEGER POINTER *data ??
Replies: 1
Views: 242

Re: ATECC508A INTEGER POINTER *data ??

Hello,

Yes the easiest way in flowcode is to create a byte array. e.g. data[64]

The square brackets force the variable to be an array of values and this will act like the pointer value in Arduino.
by Benj
Mon Jun 15, 2020 4:21 pm
Forum: Flowcode V8
Topic: PIC18F47Q10 ADC not working
Replies: 34
Views: 1931

Re: PIC18F47Q10 ADC not working

Hello, Sorry been very busy with other things. I'll have another go at this for you today and post here if the update system is still having problems. edit. please can you try adding this to the defines section of the supplementary code window via the project options. #define MX_TIMERSELECT0 I just ...
by Benj
Mon Jun 15, 2020 4:09 pm
Forum: Foro de soporte español
Topic: FLOWCODE NO SE ACTUALIZA
Replies: 1
Views: 381

Re: FLOWCODE NO SE ACTUALIZA

Hola,

Somos conscientes de los problemas y esperamos que pronto todo vuelva a funcionar normalmente.


Hello,

We are aware of the problems and hopefully everything will be back working as normal soon.
by Benj
Mon Jun 15, 2020 4:07 pm
Forum: Flowcode V8
Topic: Main application to a secondary application
Replies: 4
Views: 276

Re: Main application to a secondary application

Hello, Sounds like an interesting project. The STM32 devices have an onboard USB and Serial bootloader that you should be able to invoke. Though you may need a simple external microcontroller to enable you to do this. I beleive you simply reset the chip with a pin held in a specific state to engage ...
by Benj
Mon Jun 15, 2020 12:02 pm
Forum: Flowcode V8
Topic: MPU6050
Replies: 26
Views: 2107

Re: MPU6050

Hi Jorgen, Right I've plugged in the MPU6050 and it seems to be working ok for me. I couldn't get my Arduino board working, I think I may have killed it previously so I'll try and pick one up next time I'm in the office again. However using a dsPIC I was able to get it working and the readings seem ...