C for ARM E-blocks starter kit problem

For E-blocks user to discuss using E-blocks and programming for them.

Moderators: Benj, Mods

Post Reply
Z.K.
Posts: 6
Joined: Wed Mar 13, 2013 8:57 am
Contact:

C for ARM E-blocks starter kit problem

Post by Z.K. »

I was just setting up my new C for ARM E-blocks starter kit and I can't seem to get the board to work. I mean, I plug in the USB port and then turn the power switch to On, but though the power LED comes on, nothing else happens. Supposedly, my PC should detect the board and try to install the USB drivers, but this never happens and the board is not detected. Any ideas?

Okay, the board itself seems to be working as I can hook up the LED board and it cycles through all the LEDs. When I plug in the USB cable though it is not detected by Windows 7 and does not bring up the hardware wizard to install the drivers. One other thing. I tried plugging the board into a Windows XP machine and I get the same result.

:(

User avatar
Benj
Matrix Staff
Posts: 14929
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Contact:

Re: C for ARM E-blocks starter kit problem

Post by Benj »

Hello,

Please can you confirm if the I/O / USB jumper is in the USB position? I think you then have to press and release the reset button for the bootloader to fire up. This should last for 5-6 seconds before returning to the demo program. The new bootloader is a HID device so no driver should be needed.

This support topic may help.
http://www.matrixmultimedia.com/support ... f=11&t=790

Post Reply