EB-006-00-9 Driver issue

For E-blocks user to discuss using E-blocks and programming for them.

Moderators: Benj, Mods

User avatar
Crenwick
Posts: 127
Joined: Sun Aug 07, 2011 1:40 pm
Location: Belgium
Contact:

Re: EB-006-00-9 Driver issue

Post by Crenwick »

Hi Ben,

PICkit is back :wink:

I used the last Reflash procedure you send me (with PC-Loader).

So here are my testings in a little table. I tested one time without ZIF adapter and one time with. 16F1937 seems to have a very strange behavior with/without ZIF ??
One remark also is when programming the 18F4455 The Prg led is not on, do you have an explanation for this ?
Tests.jpg
Tests.jpg (45.67 KiB) Viewed 9466 times
Bernard

Flowcode 6 / EB006-V9

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 9100
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Contact:

Re: EB-006-00-9 Driver issue

Post by medelec35 »

I found the cause of board failing to program, and it was not a fault with mLoader or EB006v9
With the 2 second mLoader version, 16F1937 now programs just fine.

Martin
Martin

User avatar
Crenwick
Posts: 127
Joined: Sun Aug 07, 2011 1:40 pm
Location: Belgium
Contact:

Re: EB-006-00-9 Driver issue

Post by Crenwick »

medelec35 wrote:I found the cause of board failing to program, and it was not a fault with mLoader or EB006v9
With the 2 second mLoader version, 16F1937 now programs just fine.

Martin
So we he have the same results :wink:

The only thing I can't understand is that my ZIF adapter doesn't work with 16F1937 on the V9 board it's very strange :?:
Bernard

Flowcode 6 / EB006-V9

User avatar
JohnCrow
Valued Contributor
Valued Contributor
Posts: 1367
Joined: Wed Sep 19, 2007 1:21 pm
Location: Lincolnshire
Contact:

Re: EB-006-00-9 Driver issue

Post by JohnCrow »

I have just tried a test with all the devices I have.

The following all program ok when plugged into the EB006 V9
This is using the original firmware and the latest (2 second) mLoader.

16F88 OK
16F877A OK
16F1827 OK
16F1937 OK
16f1939 OK

18F2455 OK
18F2520 OK
18F4220 OK
18F4455 OK
18F4550 OK
18F4580 OK
18F4685 OK

16F84A and 16F690 both fail giving the unknown chip type error the if continued the code protect error.

I only have 1 16F690, but I'm sure the device is ok as it was working in a microchip demo board before I tried in the EB006

Will try the rest of the 40pin devices in a zif socket later.
I can also confirm what Bernard posted the 16F1937 fails if its in a zif socket plugged into the EB006. Ive tried 3 different new sockets.

With the 18F4455 the program led does flicker when programming
1 in 10 people understand binary, the other one doesn't !

User avatar
Crenwick
Posts: 127
Joined: Sun Aug 07, 2011 1:40 pm
Location: Belgium
Contact:

Re: EB-006-00-9 Driver issue

Post by Crenwick »

Just tested again with 18F4455 and Prgled flickers only two times at the beginning and then off but programming is ok.

So the only difference is the firmware on board as I have the last one that Ben send me.
Bernard

Flowcode 6 / EB006-V9

john hauton
Posts: 40
Joined: Wed Jul 08, 2009 3:23 pm
Contact:

Re: EB-006-00-9 Driver issue

Post by john hauton »

Hi, I received my eb009 yesterday, and I downloaded and expanded the driver listed under the datasheet. Straight away it found and installed the driver and the board works great. I am using win7 pro 64bit. I will try and install it today on my xp machine.
Regards john

john hauton
Posts: 40
Joined: Wed Jul 08, 2009 3:23 pm
Contact:

Re: EB-006-00-9 Driver issue

Post by john hauton »

Further to my previous post, and regarding all the problems people have, how do I tell which firmware is programmed into the eb009?
Benj if you read this can you send me the latest firmware, hopefully with instructions. I have pickit 2 and 3.
Thanks again john

john hauton
Posts: 40
Joined: Wed Jul 08, 2009 3:23 pm
Contact:

Re: EB-006-00-9 Driver issue

Post by john hauton »

Hi again, not sure if this will help, but I found that in windows7 I had to set all the exe files to 'run as administrator'
This was the only way I could get it to program correctly on my laptop (win7 home 32bit).
I have had to do this with quite a few programs, even with pickit 2 and 3. Worryingly I hear win8 is even worse!
john

dazz
Posts: 1314
Joined: Sun Jan 15, 2012 3:15 pm
Contact:

Re: EB-006-00-9 Driver issue

Post by dazz »

Hi john
Win8 isnt much worse :lol: , you just need to disable driver signing to install, then update the security of the program folder to full control for the user. (you could keep running as admin but full control is easier)

Regards
Dazz
To sign up to the V5 forum follow this link http://www.matrixmultimedia.com/forum_upgrades.php

User avatar
Crenwick
Posts: 127
Joined: Sun Aug 07, 2011 1:40 pm
Location: Belgium
Contact:

Re: EB-006-00-9 Driver issue

Post by Crenwick »

Hello,

Can we please have some status feedback about mloader and EB006-V9 Firmware ?

I have troubles with programming the internal EEPROM of the pic's (see post http://www.matrixmultimedia.com/mmforum ... =2&t=14895)

I invested in FC6 and the new EB006-V9 board last month but I have to say that there is a lot of work to do on these new versions to get it stable :?

Don't give up please :wink:
Bernard

Flowcode 6 / EB006-V9

User avatar
Benj
Matrix Staff
Posts: 15011
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Contact:

Re: EB-006-00-9 Driver issue

Post by Benj »

Hello,

Thanks for the nudge, I hadn't come across that topic yet.

I'll investigate the problem for you and let you know how I get on.

bobingabout
Posts: 45
Joined: Thu Dec 06, 2012 3:41 pm
Contact:

Re: EB-006-00-9 Driver issue

Post by bobingabout »

Crenwick wrote: I have to say that there is a lot of work to do on these new versions to get it stable :?

Don't give up please :wink:
I don't want to sound rude, but I have to agree.

in my personal opinion, it should have been far more stable than it is even now before making the V8 discontinued.

Fortunately, I'm not in any rush, it will be august or even september before my college is able to buy anything again, but I'm going to continue to push to purchase enough EBlocks programmers for a class of 20, with flowcode too. Hopefully it is stable by then.


Sorry for not being very active on here for the past couple of months, I've been busy with other things.

john hauton
Posts: 40
Joined: Wed Jul 08, 2009 3:23 pm
Contact:

Re: EB-006-00-9 Driver issue

Post by john hauton »

Hi, have there been any further developments / solutions to the problems people seem to have with this programmer?
With the 2 second delay mloader, the supplied micro (16F1937) appears to program correctly with a simple loop of text
on an eb005 lcd. I didn't use an external power supply for this test, just the usb supply. My worries are, considering all
these problems so many people are having, at some point I am likely to run into similar problems, my luck just isn't that good!
There was some reference to updating the firmware of the eb006. Benj, do you still have the latest version to download?
Thanks and regards john

big_mike
Posts: 1
Joined: Thu Sep 11, 2014 8:52 pm
Contact:

Re: EB-006-00-9 Driver issue

Post by big_mike »

I'd like to jump on the confusion bandwagon having just purchased an EB006-09 module.
After an abortive attempt to load the software on Windows 8.1 I gave up and dug out and old Dell Lattitude running XP SP3. After another struggle I sort of got the software running and connected the USB cable, an utter failure. After rummaging through this site I found two different EB006-09 driver ZIP files, one contains winusbcoinstaller2.dll dated 14/07/2009 the other contains the same file dated 01/10/2012. With either of these installed my XP is happy and device manager confirms the driver is installed. However whenever I run any function from PPP (ver 3.11.15.30) it reports that the USB cable is not connected. Reading through this thead I found reference to a new mloader which I tried (I now have mloaders dated 26/02/2014 & another 03/07/2014) sadly PPP still reports the USB cable is not connected.
For info my EB006 is connected to an EB083 and PSU and the supplied 16F1937 creates a pretty set of (currently very very expensive) flashing leds but not much else.

User avatar
Benj
Matrix Staff
Posts: 15011
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Contact:

Re: EB-006-00-9 Driver issue

Post by Benj »

Hello,
I found reference to a new mloader which I tried (I now have mloaders dated 26/02/2014 & another 03/07/2014) sadly PPP still reports the USB cable is not connected.
PPP will not work with the new v9 EB006, you have to use the mLoader software instead which replaces PPP and should allow you to load and program your hex file. To install the driver on Windows 8 you need to put it into the unsigned driver mode which is quite complex (you wouldn't do it by accident). There are lots of guides available showing you how to do this.
I invested in FC6 and the new EB006-V9 board last month but I have to say that there is a lot of work to do on these new versions to get it stable :?
We will shortly be releasing a Flowcode update which aims to tackle all these stability issues along with other things.

bobingabout
Posts: 45
Joined: Thu Dec 06, 2012 3:41 pm
Contact:

Re: EB-006-00-9 Driver issue

Post by bobingabout »

Benj wrote:We will shortly be releasing a Flowcode update which aims to tackle all these stability issues along with other things.
That sounds good.
Sorry again if I've been inactive, I went to turn my computer on on the 1st of august to find the hard drive was dead. I lost a heap of things.

It's also some coincidence I decide to load this page up once again only an hour after you post some relavant news too.

I'll probably test it at some point when it's released.

bobingabout
Posts: 45
Joined: Thu Dec 06, 2012 3:41 pm
Contact:

Re: EB-006-00-9 Driver issue

Post by bobingabout »

I went to install a demo for the latest version of flowcode to try it out, but I was met with a screen telling me I needed to enter my activation code to be allowed to continue. an interesting situation.

Post Reply