Defective EB083 board?

For E-blocks user to discuss using E-blocks and programming for them.

Moderators: Benj, Mods

Post Reply
keithh534
Posts: 54
Joined: Thu Nov 23, 2017 12:21 am
Contact:

Defective EB083 board?

Post by keithh534 »

I believe I have a defective EB083 and/or EB006 board.
These are the results I get.

EB083 Test Routine:
EB03 Test Routine.jpg
(73.14 KiB) Downloaded 2392 times
Combo Board LCD:
LCD.jpg
(78.77 KiB) Downloaded 2392 times
Combo Board LCD.fcfx
(8.27 KiB) Downloaded 102 times
More to follow.

keithh534
Posts: 54
Joined: Thu Nov 23, 2017 12:21 am
Contact:

Defective EB083 board continued

Post by keithh534 »

LED A results:
LED A.jpg
(72.2 KiB) Downloaded 2389 times
Combo Board LED A.fcfx
(8.27 KiB) Downloaded 103 times
More to follow.

keithh534
Posts: 54
Joined: Thu Nov 23, 2017 12:21 am
Contact:

Defective EB083 board continued

Post by keithh534 »

7 Segment Display results:
Segment.jpg
(79.79 KiB) Downloaded 2390 times
Segment.jpg
(79.79 KiB) Downloaded 2390 times
The B port LEDs function normally.
This concludes this test.
Attachments
Combo Board Segment.fcfx
(8.29 KiB) Downloaded 66 times

User avatar
Benj
Matrix Staff
Posts: 14852
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Contact:

Re: Defective EB083 board?

Post by Benj »

Hello,

You need to wire a cable from the +V screw terminals of the EB006 to the +V screw terminal on the EB083 board to provide power to the EB083 board.

Also why create so many individual topics? I will try and merge all your posts in to a single thread so we can more easily see what's going on.

Right I can now see the tests you have made.

The LEDs are driven directly from the micro port pins and will work fine without the +V power cable. LEDs A6 and A7 are available only when you are using the EB006 with the internal oscillator. The 2 way jumper near the crystal controls how the hardware is configured, you must also replicate this in the chip configuration settings and you may need a C code initialiser to set the internal oscillator speed as the default speed is very low.

The LCD and 7segs require the +V power cable to supply the required power.

keithh534
Posts: 54
Joined: Thu Nov 23, 2017 12:21 am
Contact:

Re: Defective EB083 board?

Post by keithh534 »

Thank you!
To answer your question about the numerous posts: I was only able to attach a maximum of 3 files per post. When I tried to attach more, it didn't work.

Post Reply