no usb connection and speed change errors

Any general or miscellaneous queries that do not fit into the other forum catagories

Moderators: Benj, Mods

Post Reply
Gaz
Posts: 18
Joined: Thu Dec 11, 2008 10:02 am
Contact:

no usb connection and speed change errors

Post by Gaz »

Hi all

Ive just purchased flowcode 3 which I am using with the pic micro dev board (version 3)

I have made a small program which flashes led's and the program simulates ok but it is very hit and miss to get the compiled hex to the chip. The program will not compile to chip (i get a no usb connection error) even though the board is powered up via a power supply.
If I assemble to hex and then use PPP to put the prog on the chip I get a working program from the chip but the led sequence is much slower than the simulation.
I am using a 16f818 with internal osc. If I change to RC osc I get a more reliable prog but still not the same simulation speed.
Any ideas folks? maybe I'm missing something simple here?

I have been using the development board for a while with no problems. It seems the problem is interfacing the flowcode with PPP.

Cheers

Gaz

User avatar
Benj
Matrix Staff
Posts: 15009
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Contact:

Re: no usb connection and speed change errors

Post by Benj »

Hi Gaz

Thats strange about your Flowcode 3 PPP not working. It is essentially the same piece of software. Might want to make sure that you have the correct chip assigned in the Chip -> Target menu. Also make sure that the Chip -> Configuration settings are correct. For the chip to run at the same speed as the simulation you must ensure that the clock speed defined in the Chip -> Clock speed menu matches your oscillator speed. The easiest way to do this is to use the 19.6608 crystal oscillator that comes with your board and set your configuration to XTAL mode (HS in the expert mode screen).

Gaz
Posts: 18
Joined: Thu Dec 11, 2008 10:02 am
Contact:

Re: no usb connection and speed change errors

Post by Gaz »

Hi Ben

I fiddled with the clock speeds and managed to get that sorted using 16f627A chip :lol: I compiled to hex then used PPP to burn it to the chip. I am still unable to compile to the chip though and still get the "no usb connection" error.

Can flowcode be used stand alone to compile to the chip or does it need PPP also to be able to do this?
Maybe the two progs are conflicting?

many thanks for helping me out so far, I'm sure we'll be conversing much more over the next few weeks, hehehe

Cheers

Gaz

User avatar
Benj
Matrix Staff
Posts: 15009
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Contact:

Re: no usb connection and speed change errors

Post by Benj »

Hello Gaz

I have an idea about what might be happening. If you have PPP open and then you try to program via flowcode then the second instance of PPP that is spawned will clash with the version that is already open and report "no usb connection". Please can you try closing the stand alone version and see if you have any more success.

Flowcode uses PPP to program our hardware but you can make it use other programming tools if you wish.

Gaz
Posts: 18
Joined: Thu Dec 11, 2008 10:02 am
Contact:

Re: no usb connection and speed change errors

Post by Gaz »

Hi Ben

Cheers for the advice. Ive sorted it by uninstalling PPP and then reinstalling it.
Installing flowcode 3 after PPP maybe overwrites a shared dll or similar and cause this error but all is working fine now with both applications open.

Cheers again

Gaz

Post Reply