USB port going to Sleep

For users of Matrix Multimedia Electronics software to discuss projects, circuits and any other electronics concepts.

Moderators: Benj, Mods

Post Reply
RobZeilinga
Flowcode V4 User
Posts: 4
Joined: Fri Sep 11, 2009 7:50 am
Contact:

USB port going to Sleep

Post by RobZeilinga »

Hi all
perhaps you can assist me.

I have build a Simple USB Datalogger & Output project based on the 2550, using the USB/Serial Driver. (the reason for the USB/Serial Driver is that the existing legacy Software drives the outputs through a serial port)

The problem is that the USB Port seems to go to sleep after a long delay ( and yes i have checked the bios of the PC and checked the Power settings for sleep & hibernation)

has anyone else experienced this?

I am experimenting Will the addition of a timed "wake-up call" from the device to the PC at the moment.

my other alternative is to return to RS232 comms (which does not seem to suffer from this problem), but will mean i have to fit a Serial Card into all of my clients' PCs

any other suggestions will be greatly appreciated.

ingobauer
Posts: 3
Joined: Tue Dec 04, 2012 10:41 am
Contact:

Re: USB port going to Sleep

Post by ingobauer »

caisses enregistreuses

According to caisses enregistreuses http://www.orderman.com/fr/tpv/orderman-columbus.html
Microsoft has been fixed this problem, but it is not successful with all PC/Notebook manufacturers. So, the OEM developers itself started giving patch for this issue. I have seen the patch upto Windows Vista version. Lenovo, HP, Dell and other people are providing this patch. Sony is providing this patch for some selective models. Go to sony support, enter or auto detect your model and check for the update. With Windows 7 SP1 your USB drives should work properly.

Z.K.
Posts: 6
Joined: Wed Mar 13, 2013 8:57 am
Contact:

Re: USB port going to Sleep

Post by Z.K. »

I am sure you know longer need this, but maybe someone else does. On the newer operating systems if you go to device manager and then to Universal Serial Bus controllers, select one of the USB hubs, there should be a power management tab where you can uncheck allowing the computer to save power by turning off the device. That should take care of your problem of the USB port going to sleep.

Post Reply