Problème EB023 SetOutValue

Forum de support pour les locuteurs de la langue française qui souhaitent écrire dans leur langue maternelle.

Moderator: Benj

Post Reply
LeoL
Posts: 2
Joined: Mon Mar 25, 2019 1:39 pm
Contact:

Problème EB023 SetOutValue

Post by LeoL »

Bonjour,
Je suis sous F7 version 7.3.0.5. J'ai un problème concernant la macro SetOutValue de la carte EB023 V1 sur une Carte EB006 PIC16f877a .
Lorsque je mets une chaine de caractère ex:A dans l'index 0 et une autre chaine ex:B dans l'index 1 mon code html contient donc %0 et %1 Les deux variables s'affiche bien dans un navigateur mais sous la forme de AB pour l'index 0 et B pour l'index 1, la dernière valeur s'affiche deux fois, une fois là où elle devrait mais aussi collé à la première valeur.
Je joins au post un petit programme pour montrer mon problème et un screen de ce que je reçois sur le navigateur.
Merci de votre aide.
Attachments
AffichageSurNavigateur.PNG
(65.07 KiB) Downloaded 2660 times
SST_serveurWeb.fcfx
(13.75 KiB) Downloaded 305 times

User avatar
LeighM
Matrix Staff
Posts: 2178
Joined: Tue Jan 17, 2012 10:07 am
Has thanked: 481 times
Been thanked: 699 times
Contact:

Re: Problème EB023 SetOutValue

Post by LeighM »

Hello,
You need to allocate space at least length of string + 1
Vous devez allouer de l'espace au moins à la longueur de la chaîne + 1
length.png
(10.88 KiB) Downloaded 2655 times

LeoL
Posts: 2
Joined: Mon Mar 25, 2019 1:39 pm
Contact:

Re: Problème EB023 SetOutValue

Post by LeoL »

Merci beaucoup pour votre rapidité, problème résolu.

Post Reply