Flow Code V5 Binary Adder tutorial Not working

Subforum for the Matrix Online Courses, discuss the courses, highlight problems or suggest amendments

Moderator: Benj

Dave Hodgson
Posts: 1
Joined: Fri Jul 06, 2012 3:42 pm
Has thanked: 1 time
Contact:

Flow Code V5 Binary Adder tutorial Not working

Postby Dave Hodgson » Fri Jul 06, 2012 4:42 pm

Hi Matrix

Many thanks for writing a superb on-line course for using Flowcode. I have followed the online course without a problem until I came to the Binary Adder program. I'm sure I have set up the three variables input1, input2, and sum correctly, and correctly set the two inputs to Port B and Port C, and the output to Port D.
Set the two SWITCHbanks to Port B and C and the LEDarray to Port D. The Calculation box is correctly set to sum = input1 + input2, and the program saved and set to use the PIC 16F1937, and I have tried the program targetted to the PIC 16F877.
But when I run the simulation I am not getting the result e.g. sum to produce anything.
I have used the Run Step Into (F8) option to step through the program, but the online tutorial indicates the Variable window which opens when the program is running should indicate the result of the variables e.g. number 11 and 15 if the turorial set up is used. I am not seeing this happen
In fact the only result that appears to be getting transferred to the LEDarray is the value set up on the C Port SWITCHbank, the program appears to be ignoring the B Port SWITCHbank setting completely. (and Yes the Port B SWITCHbank Connection option is set to Port B)

I feel sure I most not be the only person who has hit this problem any advice would be welcome

dazz
Posts: 1314
Joined: Sun Jan 15, 2012 3:15 pm
Has thanked: 514 times
Been thanked: 467 times
Contact:

Re: Flow Code V5 Binary Adder tutorial Not working

Postby dazz » Fri Jul 06, 2012 5:07 pm

Hi Dave

can you join the forum relating to your version of flowcode as you will get more help there, also can you post your flowchart so someone can have a look at it, also have you added the variable to the variable window, as your stepping into the program right click on add variable and double click the variable you want to see (do this for all variables if theres more than one), again if your running simulation at full speed you wont be able to view variables, if this is the case go into build, project options, then change as fast as poss to 1000 or less, this will slowdown the sim so you can moniteor the variables

hth
Regards

Dazz
These users thanked the author dazz for the post:
Dave Hodgson (Fri Jul 06, 2012 7:40 pm)
Rating: 5%
 
To sign up to the V5 forum follow this link http://www.matrixmultimedia.com/forum_upgrades.php

User avatar
Benj
Matrix Staff
Posts: 14655
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4644 times
Been thanked: 4266 times
Contact:

Re: Flow Code V5 Binary Adder tutorial Not working

Postby Benj » Fri Jul 06, 2012 5:13 pm

Hi Dave,

Please can you also post up your flowcode file as a attachment on the forums and I will see if I can spot what the problem is for you.

karthik.devaraj
Posts: 24
Joined: Tue Feb 12, 2013 9:03 am
Contact:

Re: Flow Code V5 Binary Adder tutorial Not working

Postby karthik.devaraj » Tue Feb 12, 2013 2:30 pm

hi,

The thing you've obtained is the flow of code value is responding or you did something wrong, same try in v4.0 and let us know,Hence the adder not working in the sense try total sheep.

One more thing , try to program the switch in active low state