PPP V3

For Flowcode users to discuss projects, flowcharts, and any other issues related to Flowcode 2 and 3.

Moderators: Benj, Mods

VLAD
Posts: 3
Joined: Fri Feb 12, 2016 10:44 am
Contact:

PPP V3

Postby VLAD » Fri Feb 12, 2016 11:05 am

Hello .
i have a big problem with my board and software . board eb006-00-06 / software V3 . on win 10 .
after programming one cip 12f675 and forgot to erase before program the entire board freeze . message - could not id cip - (i know the reset procedure)- but not working , changed the cip to 18f4550 - and the board reply same message , after a while a new message arrived - Scheme is zero or negative .
and i checked all the setiing in software for every single pic unit before erasing and programming .
the bad part is not even a new cip out of the box 18f4550 or the 16f84 not working . got the same message for very cip fitted on board . and i am sing this board for several years .
it is possible that the multiplexer 4053 or PPP CIP are faulty by any chance . or the program is hay wired to the moon :)
not a chance .
i can read some of the cips but i can't erase them .

thank's

VLAD
Posts: 3
Joined: Fri Feb 12, 2016 10:44 am
Contact:

PPP V3

Postby VLAD » Sat Feb 13, 2016 1:00 am

new Intel on this thread . digging into the last pictures before this stroke the board - --- the GPIO.0 on 12f675 in the program mode , not erasing the cip, was gating a mosfet .
saw something on the scope that the signal misbehaved but not a clue in that moment and forgot about it .
it is possible that the mos-fet (this was driving a super coil and the spike was 500v on colapse , plus we scoped the gate and a ripple of that spike as value of 0.3pp to 1pp v was found also on the gate ) --- to interfere into PGM (RB7) /gpio.0 and crack the PPP cip ???? recording i replaced the 4053 just in case ,,even if on the scope and test was working .
i used for this piece one oscilloscope with digital inputs for track and hold .
we will record the signals from every single pin on PPP cip and see if any crazy stuff .
if any idea about the PPP test or the firmware on cip please help .
we have the schematic from the board but is poor when magnified .

thank's

VLAD
Posts: 3
Joined: Fri Feb 12, 2016 10:44 am
Contact:

Re: PPP V3

Postby VLAD » Sat Feb 27, 2016 12:15 am

after checks we finally decided that the microcontroller onboard of PPP3 board is wired to the moon . it managed somehow to lock even the new pic units - when erasing the pic / or attempt to do it , the on board cip + software sets the config bits chaotic . no sense or use to config them even with a blank(not blank) hex file . ..
I bought new cips - no luck at all .
this means the firmware/ ppp3 soft is going wild .
the message we have is config1 -- bla bla bla ...... that the CP _ON ---- this is false , as we stated into program for config bits .
__config _INTRC_OSC_NOCLKOUT & _WDT_ON & _MCLRE_ON & _CP_OFF




if Matrix can help me with some suggestions will be appreciated .

User avatar
Benj
Matrix Staff
Posts: 14313
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4405 times
Been thanked: 4128 times
Contact:

Re: PPP V3

Postby Benj » Tue Mar 01, 2016 3:17 pm

Hello,

Out of interest how old is the board. It could be that one of the components in the programming chain has failed or even the PPP USB chip is known to cease working correctly after a number of years of faithful service. Could simply be down to flash data retention which is known to fail on PIC device after a number of years.

The EB006 v6 board was in operation when I joined Matrix so your probably looking at about 10 years old. Maybe time for an upgrade?