GLCD Problem

For Flowcode users to discuss projects, flowcharts, and any other issues related to Flowcode 2 and 3.

Moderators: Benj, Mods

Post Reply
cobra1
Posts: 175
Joined: Thu Feb 04, 2010 7:44 am
Contact:

GLCD Problem

Post by cobra1 »

Hi,

I am experimenting with the GLCD in flowcode, so far i have managed to initialise it and also print text, the problem is that the text is extremely faint and i cannot get any colours to show on the lcd.

i first thought it was the contrast settings but cant find any settings for this in the GLCD.c file

anyone got any ideas as to what i might be doing wrong??

User avatar
Benj
Matrix Staff
Posts: 14929
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Contact:

Re: GLCD Problem

Post by Benj »

Hello,

Which gLCD are you using. Is it an original v1 EB043 E-block or is it another one?

cobra1
Posts: 175
Joined: Thu Feb 04, 2010 7:44 am
Contact:

Re: GLCD Problem

Post by cobra1 »

Hi

Its the Lcd from a nokia 6610, phillips chipset, (ebay knock off)

i have tried looking for and also adding in the contrast settings but no good, i also found another thread on here that said you have to play with the colour settings in the code, but it gave no info on how to do such a thing.

not sure if it helps but the using 0x21 to invert the screen doesnt work either. could this just be down to incompatability??

User avatar
Benj
Matrix Staff
Posts: 14929
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Contact:

Re: GLCD Problem

Post by Benj »

Hello,

This is a good page, It helps you determine exactly which version of the display you have and also points to all the different datasheets etc.

http://www.electricstuff.co.uk/noklcd.html

You may be able to use this to get your display working correctly.

Have you looked at the datasheet for our EB043 E-block as this should show you the correct way to connect the display up.

Post Reply