Sending data to Thingspeak with GPRS

For Flowcode users to discuss projects, flowcharts, and any other issues related to Flowcode 6.

Moderator: Benj

Post Reply
keejay
Flowcode v5 User
Posts: 115
Joined: Tue Jul 23, 2013 10:02 am
Been thanked: 15 times
Contact:

Sending data to Thingspeak with GPRS

Post by keejay »

Hi guys,

I'm trying to use a SIM800L module to send data to Thingspeak. Looks like the unit has successfully connected to a GPRS connection etc. The issue that I seem to be having is the syntax using the GET command to send a data value to Thingspeak. I'm using the "SendCommand" component macro as follows to send the strings below once the connection has been established:

"AT+CIPSEND\r\n"

then

"GET https://api.thingspeak.com/update?key=X ... 25\r\n\r\n" -> XXXXX is where my key would be

But nothuing arrives on the Thingspeak website. All the fields are correct because when I insert the GET string into my web browser the value appears on Thingspeak. It may be that the modem is waiting for a Ctrl-Z character to indicate that the string is complete and needs to be sent, but I'm not sure?

Any suggestions?

User avatar
Benj
Matrix Staff
Posts: 15261
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4779 times
Been thanked: 4301 times
Contact:

Re: Sending data to Thingspeak with GPRS

Post by Benj »

You might need to include the Host section of the GET message?

e.g.
GET /pub/WWW/TheProject.html HTTP/1.1
Host: http://www.w3.org
You might be able to do some testing using this website.
https://www.hurl.it/

User avatar
LeighM
Matrix Staff
Posts: 2177
Joined: Tue Jan 17, 2012 10:07 am
Has thanked: 481 times
Been thanked: 699 times
Contact:

Re: Sending data to Thingspeak with GPRS

Post by LeighM »

You also likely need to enable SSL
Try searching SIM800L https

George_B
Posts: 124
Joined: Wed Jul 04, 2012 11:21 pm
Location: Greece
Has thanked: 47 times
Been thanked: 18 times
Contact:

Re: Sending data to Thingspeak with GPRS

Post by George_B »

Hi all,


i am trying to send some data using sim800 to MQTT server (specifically to Pub Nub).

I am lost in AT command list of the datasheet of the modem sim800.

Firstly i tried to understand an Arduino implementation with a MQTT library which sends the data to the server successfully(i tested and it is working).

Then i listen to the arduino's Tx pin which talks to Sim800 (Rx pin) and capture the data as you can see in the attached picture.
Screenshot_1.jpg
Screenshot_1.jpg (109.67 KiB) Viewed 72 times
After this i tried to create a simple program in flowcode7 so as to send the same data to the modem.


The result data from flowcode is the same as the arduino but i have no success on writing to the server.

I made some testing-changes to the FC program and you might find the data a little bit changed and different in comparison with arduino working example.

Is it something critical i am missing and the program is not working? I feel that i am very close to send the data to server successfully but i am missing something!


Any help will be really appreciated .

Thanks in advance

George
Attachments
GSM_Test.fcfx
(88.22 KiB) Downloaded 2 times

Post Reply