SIM800L

For Flowcode users to discuss projects, flowcharts, and any other issues related to Flowcode 6.

Moderator: Benj

electron67
Posts: 288
Joined: Sat Jan 12, 2008 2:08 am
Has thanked: 99 times
Been thanked: 40 times
Contact:

SIM800L

Postby electron67 » Fri Sep 16, 2016 12:42 am

Hello Stuart, I thought it best to open a new topic

viewtopic.php?f=7&t=16831&start=50#p77029

Can you please help me with the component SIM800L, as I see you did work; probe with examples published in The Matrix and you posted in the forum but I can not make it work; I'm feeding the PIC and SIM800 with 3.3v, the TX pin SIM800 is connected to C7 and RX pin SIM800 is connected to C6; I am posting a simple example, just that the connection is achieved.

I appreciate if someone could help :?:

Thanks :D
Enrique
Attachments
SIM800_HOLA_.fcfx
Flowchart
(7.1 KiB) Downloaded 226 times
SIM800Lb.jpg
sim800
(84.19 KiB) Downloaded 2348 times
SIM800La.jpg
sim800
(82.21 KiB) Downloaded 2348 times

User avatar
Benj
Matrix Staff
Posts: 13937
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4219 times
Been thanked: 3976 times
Contact:

Re: SIM800L

Postby Benj » Mon Sep 19, 2016 1:08 pm

Hello Enrique,

Have you done a 1 second flasher test to confirm your clock speed and config settings are ok.

http://www.matrixtsl.com/wiki/index.php ... ED_flasher

Also what current can your 3V3 supply handle? Note that the datasheet states a power supply of 3.4V - 4.4V. 3V3 may simply be too low.

I have used these modules before by powering everything using a single cell Lipo battery which gives a voltage between 3.7V and 4.2V. The Lipo cell should also be able to feed the high current spikes the GSM module requires which can be as high as 2A.
These users thanked the author Benj for the post:
electron67 (Mon Sep 19, 2016 4:17 pm)
Rating: 5.88%
 

electron67
Posts: 288
Joined: Sat Jan 12, 2008 2:08 am
Has thanked: 99 times
Been thanked: 40 times
Contact:

Re: SIM800L

Postby electron67 » Mon Sep 19, 2016 4:17 pm

Hello Benj

I have a current of 3.3v, 700mA, maybe it could be the current, the connections are correct, I will do these recommending me.

I will make a test.

Thanks Benj

Enrique

User avatar
Benj
Matrix Staff
Posts: 13937
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4219 times
Been thanked: 3976 times
Contact:

Re: SIM800L

Postby Benj » Mon Sep 19, 2016 4:49 pm

Hi Enrique,

Sounds like it could be both the current and the voltage. The datasheet specifically states 3.4V as the absolute minimum.

electron67
Posts: 288
Joined: Sat Jan 12, 2008 2:08 am
Has thanked: 99 times
Been thanked: 40 times
Contact:

Re: SIM800L

Postby electron67 » Mon Sep 19, 2016 7:49 pm

Hi Benj

I found a source of 0-24V 3 Amps, I will do tests this source to 4 volt, 3 Amp

Thanks
Enrique
These users thanked the author electron67 for the post:
Benj (Tue Sep 20, 2016 9:23 am)
Rating: 5.88%
 

User avatar
Benj
Matrix Staff
Posts: 13937
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4219 times
Been thanked: 3976 times
Contact:

Re: SIM800L

Postby Benj » Tue Sep 20, 2016 9:24 am

Hi Enrique,

That sounds good, fingers crossed that should solve the issues you're having. Let us know how you get on.
These users thanked the author Benj for the post:
electron67 (Tue Sep 20, 2016 9:18 pm)
Rating: 5.88%
 

electron67
Posts: 288
Joined: Sat Jan 12, 2008 2:08 am
Has thanked: 99 times
Been thanked: 40 times
Contact:

Re: SIM800L

Postby electron67 » Tue Sep 20, 2016 3:27 pm

Hi Benj,

test the circuit this day, I'll let you know the result

Thank Benj
Enrique

electron67
Posts: 288
Joined: Sat Jan 12, 2008 2:08 am
Has thanked: 99 times
Been thanked: 40 times
Contact:

Re: SIM800L

Postby electron67 » Tue Sep 20, 2016 9:18 pm

Hi Benj :D

Thank you, Benj, I am very happy, (After many tests) the problem was the voltage and current probe is an example that receives and transmits messages and works perfectly.

I appreciate the help you gave me :wink:

Enrique
These users thanked the author electron67 for the post:
Benj (Wed Sep 21, 2016 4:18 pm)
Rating: 5.88%
 

User avatar
Benj
Matrix Staff
Posts: 13937
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4219 times
Been thanked: 3976 times
Contact:

Re: SIM800L

Postby Benj » Wed Sep 21, 2016 4:19 pm

Brilliant, glad it's working correctly now. Very nice little modules but tricky to power them correctly.

electron67
Posts: 288
Joined: Sat Jan 12, 2008 2:08 am
Has thanked: 99 times
Been thanked: 40 times
Contact:

Re: SIM800L

Postby electron67 » Wed Sep 21, 2016 4:35 pm

Hi Benj,

Yes. . . knowing how to connect and feed components, it is the basis of properly functioning.

thanks a lot, Benj

Enrique

User avatar
Jan Lichtenbelt
Posts: 749
Joined: Tue Feb 17, 2009 8:35 pm
Location: Haren GN, the Netherlands
Has thanked: 103 times
Been thanked: 251 times
Contact:

Re: SIM800L

Postby Jan Lichtenbelt » Sat Jun 08, 2019 4:01 pm

I used the simple flowcode from Enrique SIM800_HOLA.fcfx. But initialising the GSM module SIM800L gives the message "No reply"(255). The red LED on the GSM module stays flickering. Has someone an idea what is wrong? I used a SIM card from my mobile phone, which needs in the phone a code. Is that a safety of the phone or is that code part of the SIM?

Kind regards

Jan

electron67
Posts: 288
Joined: Sat Jan 12, 2008 2:08 am
Has thanked: 99 times
Been thanked: 40 times
Contact:

Re: SIM800L

Postby electron67 » Sat Jun 08, 2019 5:11 pm

Hello Jan,

the led of the sim800l module flashes continuously fast when no signal is detected, when the module detects signal and the communication is linked to the sim, the led flashes slowly between 2 to 3 seconds between a flashing and another.

You can exchange the sim of other companies and do not require codes (Mexico)

The power voltage is important, I use 4.2 volt

Regards
These users thanked the author electron67 for the post:
Jan Lichtenbelt (Sat Jun 08, 2019 6:47 pm)
Rating: 5.88%
 

User avatar
Jan Lichtenbelt
Posts: 749
Joined: Tue Feb 17, 2009 8:35 pm
Location: Haren GN, the Netherlands
Has thanked: 103 times
Been thanked: 251 times
Contact:

Re: SIM800L

Postby Jan Lichtenbelt » Sun Jun 09, 2019 2:16 pm

Dear Enrique

Initilising the SIM800L gives directly code 255 (no reply). What does it means? No good communication between the microchip and the SIM800L? Or can there be an other reason?

Kind regards

Jan

electron67
Posts: 288
Joined: Sat Jan 12, 2008 2:08 am
Has thanked: 99 times
Been thanked: 40 times
Contact:

Re: SIM800L

Postby electron67 » Mon Jun 10, 2019 4:34 pm

Hello Jan,

I do not know what failure 255 (NO REPLY); in my projects with the GSM module it generates code 0 (ok), from the first second that I connect to the GSM power supply, it generates OK, even when I'm still the signal is not linked to the GSM, the LED flashes quickly and then slowly and in both cases it keeps me OK, I think it is the connection between the GSM and the PIC. . .

Best Regards

Enrique