SSD1305 Buffered not working right

A forums to allow bugs and problems with Flowcode v6 to be reported and resolved.

Moderator: Benj

hyperion007
Posts: 528
Joined: Sat Dec 01, 2012 1:23 pm
Location: Sweden
Has thanked: 49 times
Been thanked: 101 times
Contact:

SSD1305 Buffered not working right

Postby hyperion007 » Wed May 20, 2015 7:50 pm

Trying to use the SSD1305 Buffered component but it seems to be some errors with it.

The display is this one:
2.4" OLED

The interface is what they call 4-wire SPI.

Here is a photo of what it looks like:
SSD1305_Problem.jpg
(305.83 KiB) Downloaded 1166 times


Here is the test program I made in case you need it:
PIC18F26K80_SSD1305_Test.fcfx
(5.35 KiB) Downloaded 100 times


It might have something to do with how the SSD1305 uses pages and GDDRAM but I don't know. For example, the datasheet for the display says that the SSD1305 has a RAM of 132x64 but the display only uses 128x64 and I have confirmed that the first X position of the display is 2 not 0, so that's why the text starts out of frame. But I don't know why it starts on a Y coordinate in the middle of the display, nor why the random pixels are not cleared.

Please have a look at this and I'll be happy to test it out for you and report back.

User avatar
Benj
Matrix Staff
Posts: 14447
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4512 times
Been thanked: 4188 times
Contact:

Re: SSD1305 Buffered not working right

Postby Benj » Thu May 21, 2015 4:50 pm

Hello,

Here is the source for the component, looks like the display might have a none standard paging system. I have come across a few which are interlaced and it's basically down to the initialisation commands to sort out the correct addressing mode.

glcd_SSD1305_buffered.fcfx
(80.03 KiB) Downloaded 98 times


Let me know how your getting on.

hyperion007
Posts: 528
Joined: Sat Dec 01, 2012 1:23 pm
Location: Sweden
Has thanked: 49 times
Been thanked: 101 times
Contact:

Re: SSD1305 Buffered not working right

Postby hyperion007 » Thu May 21, 2015 5:14 pm

Ok, I guess you have this a bit down on your to-do list then?
I know I wont figure it out on my own so please have a look at this as soon as you are able to. I will however take a look at the source code anyway. I don't have more of these displays, otherwise I would send you one as to aid you when troubleshooting.

hyperion007
Posts: 528
Joined: Sat Dec 01, 2012 1:23 pm
Location: Sweden
Has thanked: 49 times
Been thanked: 101 times
Contact:

Re: SSD1305 Buffered not working right

Postby hyperion007 » Fri May 22, 2015 2:51 pm

After looking at the source code I know I won't understand what is what :)
But I took a longer look at the datasheet and I think that you have to re-map the GDDRAM because the display will always start on PAGE2 which is either COM16-COM23 or if the standard remap it would be COM47-COM40, but I think it needs to be remapped so that PAGE2 is either COM0-COM7 or COM63-COM56 depending on what orientation the display is (COM Normal / Remapped (C0h/C8h))

And the 128 pixel wide active area is centered so that should be easy enough to alter in the source code but I don't know where to do that without messing up other functions etc.

SSD1305_page_column_remap.JPG
(296.73 KiB) Downloaded 1155 times


SSD1305_COM_vs_ROW_vs_RAM.JPG
(556.74 KiB) Downloaded 1155 times

User avatar
Benj
Matrix Staff
Posts: 14447
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4512 times
Been thanked: 4188 times
Contact:

Re: SSD1305 Buffered not working right

Postby Benj » Wed May 27, 2015 11:13 am

Hello,

All of the display setup should be done inside the initialise macro. You shouldn't have to change anything else.

I would make a note of what is there now so you can go back if you need to.

Think of the component source as a test bed. You can add code to the main macro such as the initialise macro and the print string macro and configure the project for your chip so you can compile the source to drive your hardware. Once this is working the component can be exported again to work with other projects.

hyperion007
Posts: 528
Joined: Sat Dec 01, 2012 1:23 pm
Location: Sweden
Has thanked: 49 times
Been thanked: 101 times
Contact:

Re: SSD1305 Buffered not working right

Postby hyperion007 » Thu May 28, 2015 8:23 am

Hi Ben,

I've tried working this one out but I simply don't understand what does what. I can't spend more time on this because it's not moving forward at all so I really do need your help with this one.

I did find another sample code for the SSD1305 but I don't know it if holds any clues to what might be the issue with the component.

https://code.google.com/p/cpassgen/sour ... 305.c?r=86