Page 1 of 1

FC v6.1.2 on win8.1 can't compile to chip

Posted: Thu Jul 16, 2015 10:50 am
by chipfryer27

New machine running w8.1 and installed FCv6.1.2.

First issue was getting the machine to recognise the EB006 v8 board. Problem due to missing "hash" file and a quick search of the forum suggested disabling automatic software verification which then allowed me to manually confirm installation of drivers which resolved issue. Using PPP I can erase a chip.

Trying to Compile to Chip wasn't successful (very basic flash an led test).

Compiler Options has the location as: $(appdir)compilers\pic\boostc\boostc_$(family:/12F/16F).exe

Much like the post by TomC in this forum ( viewtopic.php?f=59&t=15432 ) my error code is:

ERROR: GetShortPathName().The system cannot find the file specified.

This suggests to me that the problem is related to an issue with short path names and from within TomC's post I saw a reference to this being disabled from DavidA. Following that link I see that my NtfsDisable8dot3NameCreation is set to 2. Far from an expert I turned to Google but can't find a reference to enabling short path names.

Does anyone have any idea on how to resole this problem? All help gratefully appreciated.


Re: FC v6.1.2 on win8.1 can't compile to chip

Posted: Fri Jul 17, 2015 9:44 am
by DavidA

I would suggest you try Flowcode in "safe mode", this could help determine if some other piece of software is interfering:

Win 8: ... -safe-mode

Are you using an Antivirus program which may be blocking parts of Flowcode? This has been known to be a cause as well, i would check the list of programs being blocked by your antivirus.

Re: FC v6.1.2 on win8.1 can't compile to chip

Posted: Fri Jul 17, 2015 11:47 am
by chipfryer27

Thanks for your reply.

I'm running Norton with latest signatures and when the problem first arose I disabled AV completely but it made no difference. I also whitelisted FC folder for good measure (but...... can't remember if I did this before or after the reboots that follow below).

Hunting around the web when searching for "enable short path names" gave a ton of replies on disabling it and eventually, after digging into lots of replies about disabling, I found a piece that suggested I set my NtfsDisable8dot3NameCreation to 0.

Tried this but it made no difference, so I set it back to its original value (2) and rebooted. Reading some more on the subject suggested that after enabling SPN, any new install would be enabled. My plan then was to reset NtfsDisable8dot3NameCreation to 0 and then reinstall FC.

Before doing so this morning, I tried as you suggested.

I rebooted into safe mode. I then had to go find a mouse as my trackpad stopped working..<s>
I loaded my test file (basic flash LED) and tried to compile to chip.
This time I did compile but the process failed when mLoader couldn't detect my board (no drivers loaded, unsurprisingly)
Happy that I had gotten this far I rebooted (normal).
Using mLoader I could load the hex file and send to chip.

Now, much to my great surprise and joy, I find that I can compile directly from FC to chip.

I have little idea as to why it now works, but I see that Windows did an update during the night so that might explain it.

Thanks for your help and also for your previous post relating to NtfsDisable8dot3NameCreation. Appreciated. I can now go and find something else to ask help about <s>