C for ARM not running

For C and ASSEMBLY users to post questions and code snippets for programming in C and ASSEMBLY. And for any other C or ASM course related questions.

Moderators: Benj, Mods

Post Reply
Posts: 1
Joined: Mon Jul 27, 2009 8:02 am

C for ARM not running

Post by markb »

I've installed C for ARM on win7 64 bit. I get the "serial number not found or incorrect" when I try to run the course. I found the registry fix on the support page and tried it but it made no difference. Also, during the installation, I got" dpinst.exe does not run ....". Tried to download the latest drivers but again, it had no effect.


User avatar
Matrix Staff
Posts: 1065
Joined: Fri Apr 23, 2010 2:18 pm
Location: Matrix Multimedia Ltd

Re: C for ARM not running

Post by DavidA »

Hello mark,

To get C4ARM working on 64 bit machines you will need to follow the procedures in these two FAQs

http://www.matrixmultimedia.com/support ... f=11&t=587 - 64-bit PC serial number not found or incorrect

http://www.matrixmultimedia.com/support ... f=11&t=790 - Getting C4ARMs working on 64bit machines

The registry fix should work and give you access to the course, a common mistake is not running the file that is downloaded as an administrator by right clicking and selecting "Run as Administrator".

The dpinst.exe error is because the installer is trying to install 32bit drivers. This is covered in part by the second FAQ topic as the bootloader in the Eblock needs updating.

Posts: 3
Joined: Tue Dec 17, 2013 12:42 pm

Re: C for ARM not running

Post by angleblue63 »

Hi dazz,
i'm currently working on it. maybe it will take some time because i have classes and i can only do it during nighttime. if i finished the flowchart, i'm gonna post it right away. thanks again.. :D

Post Reply