IR sensors with flowcode 9

For Formula AllCode users to discuss projects, programs, and any other issues related to the Formula AllCode robotics platform.

Moderators: Benj, Mods

Post Reply
reedas
Posts: 9
Joined: Fri Jan 05, 2018 3:59 pm
Has thanked: 2 times
Contact:

IR sensors with flowcode 9

Post by reedas »

I am having problems reading from the IR sensors on the allcode hardware itself, it does simulate ok. It is only able to successfully read and display values for the left front and left sensors all the other sensors show very low (0,1 or 2 mostly) even when very close to objects on an actual allcode.

I am using flowcode 9
only Left(LT) and left front(LF) read and display correctly
only Left(LT) and left front(LF) read and display correctly
allcode sensor.jpg (169.25 KiB) Viewed 2693 times
irtest11.fcfx
(15.03 KiB) Downloaded 63 times
I have set the students a maze running task as their final assignment and this may be difficult to accomplish with limited vision.

Thanks,

Andrew

User avatar
LeighM
Matrix Staff
Posts: 2177
Joined: Tue Jan 17, 2012 10:07 am
Has thanked: 481 times
Been thanked: 699 times
Contact:

Re: IR sensors with flowcode 9

Post by LeighM »

Hi Andrew,
Sorry for the delay in getting back to you.
Do you have more than one Formula Allcode,
such that we can determine if it is just this one unit that might be at fault?

reedas
Posts: 9
Joined: Fri Jan 05, 2018 3:59 pm
Has thanked: 2 times
Contact:

Re: IR sensors with flowcode 9

Post by reedas »

Hi Leigh,

It is the same on all the Allcode rovers we've tried. Another issue that may be related is that the logo commands cause the Allcode rover program to hang.

Thanks Andrew

User avatar
Benj
Matrix Staff
Posts: 15261
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4779 times
Been thanked: 4301 times
Contact:

Re: IR sensors with flowcode 9

Post by Benj »

Hello Andrew,

Many thanks for letting us know I am now in the process of investigating this one for you. There seems to be some kind of problem relating to the choice of MCU target which may or may not be causing the problem.

User avatar
Benj
Matrix Staff
Posts: 15261
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4779 times
Been thanked: 4301 times
Contact:

Re: IR sensors with flowcode 9

Post by Benj »

Hello,

Many thanks for letting us know on this one, sorry it took a while for us to replicate and then find the cause but this has now been resolved in the latest v9 and v8 updates.

Post Reply