problem comp vs2015 and c++

For Formula AllCode users to discuss projects, programs, and any other issues related to the Formula AllCode robotics platform.

Moderators: Benj, Mods

Kjell Holen
Posts: 7
Joined: Sun Apr 24, 2016 2:32 am
Been thanked: 2 times
Contact:

problem comp vs2015 and c++

Postby Kjell Holen » Thu Dec 22, 2016 5:14 pm

I have a few question to the setup. I use Windows 10, and visual studio 2015 c++
Want to test c++ and the robot
I assume I do somthing wrong with setupo/ compil. Glads if someone could give some hints,
Have downloaded 2 dif. code example.
Should I use Slave-allcode_examples or FA_CP_Formula Allcode C++ VS2015
I use visual studio c++ 2015. Should I run VSCodeSetup-1.8.0.exe
must the file-tree be: /document/visual studio 2015/

I have tried, but got error.
Startet VS and File Project/solution and brosed to tne Formula AllCode.vcxproj selecdet
got error could not find faslave.lib but the file was there

rgds

.

User avatar
Benj
Matrix Staff
Posts: 14655
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4646 times
Been thanked: 4267 times
Contact:

Re: problem comp vs2015 and c++

Postby Benj » Thu Dec 22, 2016 5:58 pm

Hello,

Make sure the FASlave.dll file is in the same directory as the exe file and it should work ok.

FASlave.zip
(11.27 KiB) Downloaded 235 times


You might also need to include the faslave.lib file in the project.