WS2811 Component

A forums to allow bugs and problems with Flowcode v7 to be reported and resolved.

Moderator: Benj

Post Reply
mnf
Valued Contributor
Valued Contributor
Posts: 806
Joined: Wed May 31, 2017 11:57 am
Contact:

WS2811 Component

Post by mnf »

In the WS2811 component the Red and Green arguments seem to be swapped (or just mislabeled)

So SetAllLEDColour(0, 255, 0) gives a RED string of LEDs instead of green...

Martin

User avatar
Benj
Matrix Staff
Posts: 14873
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Contact:

Re: WS2811 Component

Post by Benj »

Thanks Martin,

I'll look into this problem for you. On some of the LEDs we have here the Red and Green is swapped, I wonder if this is by design and open to be manufactured differently based on supplier or a mistake on the batch of LEDs we bought in? Either way I shhould be able to add the option as a property to suit both implementations.

I have a love hate relationship with these no brand Chinese products :wink:

User avatar
STibor
Posts: 263
Joined: Fri Dec 16, 2011 3:20 pm
Contact:

Re: WS2811 Component

Post by STibor »

Hello!

The WS28xx LED component can be manually parameterized.
Very good component.
One difficulty, interruptions (int, port) cause faulty display.
Attachments
custom_WSLED.png
(41.29 KiB) Downloaded 2664 times

mnf
Valued Contributor
Valued Contributor
Posts: 806
Joined: Wed May 31, 2017 11:57 am
Contact:

Re: WS2811 Component

Post by mnf »

Swapping to WS2812 - swaps green / red and could be that is what the chips are... No distinguishing markings - a bit like sexing penguins. (They seem pretty much compatible apart from the colour order)

I got myself into all sorts of confusion - as the colours in my 24 bit bitmap don't seem to be in BGR format promised by the wikipedia page. Still I managed to get bitmaps off SD card and onto a string of LEDs in a pleasing manner.

Martin

User avatar
STibor
Posts: 263
Joined: Fri Dec 16, 2011 3:20 pm
Contact:

Re: WS2811 Component

Post by STibor »

Hello!

Controller: Arduino Nano (Atmega328 smd @ 16MHz)
The WS2812 LED does not work when data output is D0 and D1 (uart rx / tx).
Version Flowcode v7.2.1.4 here in the office, would not update if not needed (many projects would be affected by the upgrade).

Post Reply