Converter is not working

A forums to allow bugs and problems with Flowcode v7 to be reported and resolved.

Moderator: Benj

User avatar
Osta
Posts: 146
Joined: Tue Jul 05, 2016 9:42 am
Been thanked: 13 times
Contact:

Converter is not working

Postby Osta » Thu May 17, 2018 12:50 pm

After I prescribed Compare$()
Stopped working ToString$()
Remained workers only the text !
This is after update!!!
And all I had from this project to remove all the macros and put them zanovo
Because after the update the compiler simply did not see them!!!!
In General horror!!!

User avatar
Osta
Posts: 146
Joined: Tue Jul 05, 2016 9:42 am
Been thanked: 13 times
Contact:

Re: Converter is not working

Postby Osta » Thu May 17, 2018 1:03 pm

MD.fcfx
Proj
(14.33 KiB) Downloaded 50 times

User avatar
Osta
Posts: 146
Joined: Tue Jul 05, 2016 9:42 am
Been thanked: 13 times
Contact:

Re: Converter is not working

Postby Osta » Thu May 17, 2018 1:30 pm

The compiler stopped working at all !!!

User avatar
LeighM
Matrix Staff
Posts: 1938
Joined: Tue Jan 17, 2012 10:07 am
Has thanked: 466 times
Been thanked: 664 times
Contact:

Re: Converter is not working

Postby LeighM » Thu May 17, 2018 1:34 pm

Hi,
I am not sure exactly what problem you are reporting.
But I did notice a couple of issues:

Text normally needs the background drawing too, so you need transparency turned off...

transparent_0.jpg
transparent_0.jpg (61.45 KiB) Viewed 1435 times

C code does not simulate, so the variable will not increment in the simulator unless you use a calculation icon...

gain.jpg
gain.jpg (13.52 KiB) Viewed 1435 times


Hope that resolves your problem, if not please could you give more details.
Leigh

User avatar
Osta
Posts: 146
Joined: Tue Jul 05, 2016 9:42 am
Been thanked: 13 times
Contact:

Re: Converter is not working

Postby Osta » Thu May 17, 2018 1:51 pm

I'm not using the simulator!
Can I use my code ?
I have an electronic Board with a processor.
Now nothing works !!!
SPI - not working !
display not working!
The display is not initialized
and no cleaning !
Previously cleaned!

User avatar
LeighM
Matrix Staff
Posts: 1938
Joined: Tue Jan 17, 2012 10:07 am
Has thanked: 466 times
Been thanked: 664 times
Contact:

Re: Converter is not working

Postby LeighM » Thu May 17, 2018 3:06 pm

Could you make the above changes, then "Compile to chip" and post your MD.msg.txt file?

User avatar
Osta
Posts: 146
Joined: Tue Jul 05, 2016 9:42 am
Been thanked: 13 times
Contact:

Re: Converter is not working

Postby Osta » Thu May 17, 2018 3:52 pm

It's my fault.....
I made a delay at the beginning of the code and everything began to work!!!
Probably a programming problem...
My apologies!!!!
I'm confused with the Compare$ function
With respect Osta :)
MMD.fcfx
New
(10.37 KiB) Downloaded 61 times

User avatar
LeighM
Matrix Staff
Posts: 1938
Joined: Tue Jan 17, 2012 10:07 am
Has thanked: 466 times
Been thanked: 664 times
Contact:

Re: Converter is not working

Postby LeighM » Fri May 18, 2018 8:06 am

OK, glad it's now working.

The Compare$ function returns 0 if the strings are the same.