Arduino nano problems

A forums to allow bugs and problems with Flowcode v7 to be reported and resolved.

Moderator: Benj

Post Reply
User avatar
STibor
Posts: 263
Joined: Fri Dec 16, 2011 3:20 pm
Contact:

Arduino nano problems

Post by STibor »

Hello!

New Win10 I installed Flowcode v7 and the current update.
"Https://www.matrixtsl.com/temp/FC7_Late ... -07-18.zip"
There are some problems with the program.
Target hardware: Arduino nano
1 .: Missing ADC channel, AN6, AN7 can not be selected.
2.: Component MIDI:
Channel hardware "Channel1", no incoming data, does not work.
Channel software, there are incoming data, it works.
3.: RS232, UART:
Interrupt UART0RX does not work, incoming data does not generate interruption, no incoming data.

Please look at the bugs.

User avatar
Benj
Matrix Staff
Posts: 14865
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Contact:

Re: Arduino nano problems

Post by Benj »

Hello,

Bug 1 is easy to solve. The attached definition files should solve the missing ADC pins problem. Simply copy into your "Flowcode 7/FCD/AVR" folder.
Arduino Nano 168.fcdx
(13.8 KiB) Downloaded 69 times
Arduino Nano 328.fcdx
(13.79 KiB) Downloaded 74 times
I'll investigate the other issues for you.

User avatar
STibor
Posts: 263
Joined: Fri Dec 16, 2011 3:20 pm
Contact:

Re: Arduino nano problems

Post by STibor »

Hello!

Thanks.
I have noticed that the UART interruption works when I use the UART Send Macro after the UART reading macro, in the UART0 RX interrupts.
Attachments
midi_test_rxint.fcfx
(13.99 KiB) Downloaded 64 times

Post Reply