MCP23017 Flowcode 7 problem

A forums to allow resolved bugs and problems with Flowcode v7 to be stored and marked as resolved.

Moderator: Benj

Post Reply
radist73
Posts: 36
Joined: Mon Dec 22, 2014 10:04 pm
Location: TALLINN
Contact:

MCP23017 Flowcode 7 problem

Post by radist73 »

Hello,
Please help, mcp23017 test program works fine on Flowcode v5 and v6, but hasnt work on v7, Program stop working after I2C master component macro TransmitByte. Simulation in console show that all ok.
I use PIC18F2620, v6 program works fine.
New patch for Flowcode7 today installed, no result for this problem.
Attachments
2620v6_test1.fcfx
v6 program works fine
(7.38 KiB) Downloaded 122 times
2620_i2ctest.fcfx
v7 program
(9.18 KiB) Downloaded 118 times

radist73
Posts: 36
Joined: Mon Dec 22, 2014 10:04 pm
Location: TALLINN
Contact:

Re: MCP23017 Flowcode 7 problem

Post by radist73 »

Hello,
With updated ModbusMaster component http://www.matrixtsl.com/mmforums/viewt ... bus#p73930 my project with Modbus and I2C MCP23017 works fine on Flowcode v6.
In Flowcode v7 MCP23017 not working.
Any ideas? Thanks!

User avatar
Benj
Matrix Staff
Posts: 14848
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Contact:

Re: MCP23017 Flowcode 7 problem

Post by Benj »

Hello,

You have the "Extended CPU" Configuration setting set to enabled, Change this to disabled and hopefully your program should run correctly using v7.

Let us know how you get on.

radist73
Posts: 36
Joined: Mon Dec 22, 2014 10:04 pm
Location: TALLINN
Contact:

Re: MCP23017 Flowcode 7 problem

Post by radist73 »

Works fine! Thank you for help!

Post Reply