Compile error

An area to discuss AVR and Arduino specific problems and examples

Moderator: Benj

Post Reply
igore14105
Posts: 2
Joined: Wed Dec 20, 2017 12:07 pm
Contact:

Compile error

Post by igore14105 »

Hello everyone. I have one small problem. Cannot compile fex file, and programe write this error:

C:\Users\D395~1\DOCUME~1\first>"E:\163C~1\FLOWCO~1\COMPIL~1\avr\BATCHF~1\..\bin\avr-gcc.exe" -mmcu=atmega8 -Os -funsigned-char -o "C:\Users\D395~1\DOCUME~1\first\Flowcode1.elf" "C:\Users\D395~1\DOCUME~1\first\Flowcode1.c" -lm
C:\Users\D395~1\DOCUME~1\first\Flowcode1.c:43:49: error: E:\????????\Flowcode7\CAL\internals.c: Invalid argument
C:\Users\D395~1\DOCUME~1\first\Flowcode1.c:77:48: error: E:\????????\Flowcode7\CAL\includes.c: Invalid argument
C:\Users\D395~1\DOCUME~1\first\Flowcode1.c: In function 'FCD_03d91_led_base1__TurnOn':
C:\Users\D395~1\DOCUME~1\first\Flowcode1.c:92: error: 'B' undeclared (first use in this function)
C:\Users\D395~1\DOCUME~1\first\Flowcode1.c:92: error: (Each undeclared identifier is reported only once
C:\Users\D395~1\DOCUME~1\first\Flowcode1.c:92: error: for each function it appears in.)
C:\Users\D395~1\DOCUME~1\first\Flowcode1.c: In function 'FCD_03d91_led_base1__TurnOff':
C:\Users\D395~1\DOCUME~1\first\Flowcode1.c:109: error: 'B' undeclared (first use in this function)
Error returned from [avr-gcc.exe]
Completed compilation, return = 1
E:\програмы\Flowcode7\compilers\avr\batchfiles\avra.bat reported error code 1
FINISHED

Can you help me with this problem. I will be appreciative

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8925
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Contact:

Re: Compile error

Post by medelec35 »

Hi igore14105,
Welcome to Matrix forums.
I have moved your post to a more suitable section.
As you have not attached your flowchart, at best we can only guess what the issue is.

My guess is you have not assigned a LED component to a suitable port E.G A0

Martin
Martin

User avatar
LeighM
Matrix Staff
Posts: 2052
Joined: Tue Jan 17, 2012 10:07 am
Contact:

Re: Compile error

Post by LeighM »

E:\програмы\Flowcode7\compilers\avr\batchfiles\avra.bat reported error code 1
There also might be an issue with non-ascii characters in the installation path

Post Reply