HX711 Not zeroing

For Flowcode users to discuss projects, flowcharts, and any other issues related to Flowcode 8.

Moderator: Benj

KrisJeff
Flowcode v5 User
Posts: 22
Joined: Sun Feb 01, 2009 5:32 pm
Has thanked: 1 time
Contact:

HX711 Not zeroing

Postby KrisJeff » Fri Mar 27, 2020 9:03 pm

Several months ago I downloaded the example for the HX711 and had the example running on my BLOO80 EBlocks 2 programmer.
I'm trying to design a weighing device to weigh my gas bottles so I can see how much gas is left in the bottle.

I acquired a load cell and connected this to the HX711 and then I duly connected this to my BL080 programmer. In time I got this working but further design was necessary.

I've just resurrected the project and I cannot get this working. The fault lies in the Zeroing of the HX711 by input A2. This used to zero the output, however now I get 7208 instead of zero? Nothing has changed from previous as far as I'm aware. The only thing I can think of is there has been a couple of updates recently, and I wonder if this has had an effect on my programme? I've attached my programme as I'm not too sure about the chip properties? As far as I'm aware this is pretty much as per the example I downloaded from your Website.

Originally I had it on test for ages to check on any drift over time. I had no problems with zeroing then? It simulates a zero reset, but unfortunately
it won't output zero only 7208? It does this every time. Anyone any idea's? I cant understand why it worked previously and not now. Nothing has changed that I'm aware of? Why 7208?
Attachments
HX711_Test Prog16F18877.fcfx
(10.88 KiB) Downloaded 3 times

jgu1
Posts: 1179
Joined: Tue Oct 06, 2009 9:39 am
Has thanked: 1104 times
Been thanked: 295 times
Contact:

Re: HX711 Not zeroing

Postby jgu1 » Sat Mar 28, 2020 7:11 pm

Hi Krisjeff!

Have a look here: viewtopic.php?f=76&t=20346&p=90505&hilit=hx711#p90505
Well ok, I use an Arduino in the testprogram, maybe something you can use.

Br Jorgen.