T6963C macro FC7 does not work. FC8 works

Moderator: Benj

Dutch
Posts: 77
Joined: Mon Aug 19, 2013 8:38 am
Location: Netherlands
Has thanked: 23 times
Been thanked: 4 times
Contact:

T6963C macro FC7 does not work. FC8 works

Postby Dutch » Mon Jan 20, 2020 7:39 pm

T6963C macro FC7 does not work. FC8 works

I made a test program around a LGM12864 Longtech display with T6963C controller, but it does not show the correct things on the display. :? The display came out a working unit.
After searching for answers I found a similar tread in these forums about a fix in a component macro for a GLCD display. not this one though. I updated my FC7 to latest version but still no good. I installed the 30 day trail FC8 and now all works without changes!

I am not upgrading to FC8 yet. is there a possibility to have the component macro fixed for my future FC7 use after the FC8 expires :wink:

Let me know if you guys need more info. im running out of my FC8 trial licence...
Regards Angelo

User avatar
Benj
Matrix Staff
Posts: 14676
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4660 times
Been thanked: 4286 times
Contact:

Re: T6963C macro FC7 does not work. FC8 works

Postby Benj » Tue Jan 21, 2020 11:15 am

Hello Angelo.

Thanks for letting us know. Please try this updated component by copying to your "C:\Program Files (x86)\Flowcode V7\Components" folder.

gLCD_T6963C.fcpx
(34.37 KiB) Downloaded 18 times


Hopefully it will solve the problem in v7.

Let us know how you get on.

Dutch
Posts: 77
Joined: Mon Aug 19, 2013 8:38 am
Location: Netherlands
Has thanked: 23 times
Been thanked: 4 times
Contact:

Re: T6963C macro FC7 does not work. FC8 works

Postby Dutch » Sat Jan 25, 2020 6:23 pm

Thank you Ben!

I had to rebuild my project hardware but tested it now with FC7 and works :D.
I realize I posted this FC7 problem in the FC8 section :? glad you sorted it anyway.

But, I ordered a different Oled gLCD display with an SSD1322 and chose the parallel (6800) macro. The display also does SPI-3 and SPI-4 but there is no macro for that. (edit: the 'buffered' macro looks to be the SPI-4.. il give it a try.)
all simulates fine but ones I compile the project as hex the FC7 crashes :roll: and of coarse in FC8 it works :wink: ..

I did setup a simple test with two different displays and even if I also 'disable' the SSD1322 parallel macro it goes wrong. if I take it completely off it compiles.
can you check that too please?

Angelo.
Attachments
test_ssd1322_fc7.fcfx
(11.71 KiB) Downloaded 7 times

Dutch
Posts: 77
Joined: Mon Aug 19, 2013 8:38 am
Location: Netherlands
Has thanked: 23 times
Been thanked: 4 times
Contact:

Re: T6963C macro FC7 does not work. FC8 works

Postby Dutch » Sun Jan 26, 2020 11:53 pm

I did all kind of tests with my SSD1322 Oled display. simple sets with initialize and a circle being drawn. I did build a combination in 6800 mode. And in SPI-4 mode (SSD1322 buffered) both to no reaction of the screen whatsoever. in 8080 modus I at lease get the screen on but all noise. (all 64x256 pixels have a wild mixed gray value but stay exactly frozen like that) sigh... of coarse I measured out all wires and seem to be good :? .
If I take controller off the display still shows this image ...
Only thing I dont measure with my scope is a signal on data7. further all kind of signals.. I hope with the fix of FC7 SSD1622 macro there is something found.
I really do hope I made a mistake here :) but its pretty deep hidden then :oops:
Attachments
IMG_0068.jpg
IMG_0068.jpg (36.24 KiB) Viewed 298 times

User avatar
Benj
Matrix Staff
Posts: 14676
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4660 times
Been thanked: 4286 times
Contact:

Re: T6963C macro FC7 does not work. FC8 works

Postby Benj » Mon Jan 27, 2020 11:16 am

Hello,

I've compared the v7 and v8 components for the SSD1322 and nothign is jumping out at me.

There was a fix for the component posted here, have you applied these fixes to your v7?
viewtopic.php?f=63&t=19743

Dutch
Posts: 77
Joined: Mon Aug 19, 2013 8:38 am
Location: Netherlands
Has thanked: 23 times
Been thanked: 4 times
Contact:

Re: T6963C macro FC7 does not work. FC8 works

Postby Dutch » Mon Jan 27, 2020 6:02 pm

yes pretty recent did run the updates when i had the other LCD issue but just did them again and its now at version 7-3-0-6.

in the updated list the date for the gLCD SSD1322 is 7-11-2017 and I cant find it in the latest update list of components. is that correct? I see you mentioned it in the tread! I might be wrong here...

after latest update (installed correctly I assume) and hardware reboot my FC7 still crashes after I want to compile.. can I transfer the FC license to another computer and de-install here or run one at the time? this computer is getting tired :lol:

But.. I still have a day left or so of my FC8 trial.. and the SSD1322 macro is correct you say.. :( my lcd must be broken.. (why the expensive new stuff break and the free old stuff survives :lol: )
EDIT: FC8 has expired.. no tests anymore :(



top one is when I take ssd1322 off the lists and asks me to save the file first as expected.
bottom one is 'with' ssd1322.. warning is CF don't react anymore and needs to be terminated.
Attachments
FC CRASH2.PNG
FC CRASH2.PNG (58.2 KiB) Viewed 287 times
FC CRASH.PNG
FC CRASH.PNG (159.96 KiB) Viewed 287 times