Import old projects

Moderator: Benj

User avatar
STibor
Posts: 262
Joined: Fri Dec 16, 2011 3:20 pm
Has thanked: 111 times
Been thanked: 112 times
Contact:

Import old projects

Postby STibor » Tue Nov 20, 2018 6:30 am

Hello!

I bought the Flowcode v8 program, thank you for the extra black Friday 30% discount. :D

How to import old Flowcode v4 and v5 project files?
I can not find the import function in the file menu.

User avatar
Benj
Matrix Staff
Posts: 14299
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4394 times
Been thanked: 4123 times
Contact:

Re: Import old projects

Postby Benj » Tue Nov 20, 2018 12:03 pm

Hello,

Do you have many files to upgrade? We recently removed v4 and v5 upgrade support from v8.1.

You can send me the files via PM and I will convert them to v8 for you.
These users thanked the author Benj for the post:
STibor (Tue Nov 20, 2018 5:43 pm)
Rating: 5.26%
 

iain wilkie
Posts: 89
Joined: Tue Jul 14, 2009 4:37 pm
Has thanked: 10 times
Been thanked: 8 times
Contact:

Re: Import old projects

Postby iain wilkie » Tue Nov 20, 2018 12:20 pm

ARRRG !!!

So I updated to 8.1 (still evaluating for purchase) so this means I can no longer import my previous V4 programs !!!
I realize there may be a bit of incompatibility that may need attention when doing this but a least you could move the bulk
of a program over to V8 very easily.

I also noted that when I updated to 8.1 my up and running program in V8 stopped working as it imported an old ATTiny13.fcdx that doesn't work and I have to reload a new one sent from MM ...... All a bit of a mess this !!!!

Iain

User avatar
Benj
Matrix Staff
Posts: 14299
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4394 times
Been thanked: 4123 times
Contact:

Re: Import old projects

Postby Benj » Tue Nov 20, 2018 1:46 pm

Hello Iain,

V4 was a long time ago and being able to move from v4 to v8 is a massive jump that is very difficult to maintain going forward. I hope you can understand this.

Once you have moved the v4 programs over to v8 you shouldn't have to do it again. If you have a copy of v6 or v7 installed then this can be used to do the conversion to 8.1. Or pass a file to us and we can do the conversion for you.

If you feel strongly that we should still be supporting upgrades from v4/v5 then please let us know so we can gauge how useful this would be and hence how much time we should spend on it.

The 8.1 update system should be up and running again now. All v8 updates from the update system were copied into the Flowcode default files for the 8.1 installation. Maybe you clicked no when running 8.1 for the first time and so the newer files were not copied into your data directory? Either way we did our absolute best to ensure things went smoothly so we are sorry if you found things became broken. At least they are working again now so that's good.

iain wilkie
Posts: 89
Joined: Tue Jul 14, 2009 4:37 pm
Has thanked: 10 times
Been thanked: 8 times
Contact:

Re: Import old projects

Postby iain wilkie » Tue Nov 20, 2018 3:42 pm

Hi Benj,

I fully understand that the jump from V4 to V8 is massive and appreciate that there is no doubt this would cause problems. As we have new projects coming up where I was going to use Flowcode it became apparent to me that we should upgrade to V8 and as part of the learning curve for V8 I obviously started by looking at some of our older V8 programs to get a feel for V8 which I have to say I am very happy with.
The fact that in the future if we ever do need to bring an older V4 program into V8 you have made the offer that this can be done by yourselves so I'm very happy about that.
On the bad ATTiny13.fcdx file ... I had downloaded the 30 day trial of V8 and was running that when I found there was a problem with the interrupt. On of your guys sent me a new ATTiny13.fcdx file that cured the problem. I couple of days later I noticed there was a patch for 8.1 so I installed that and found that the original interrupt problem had returned and I needed to copy the new .fcdx file into the data again.
As we would be buying a pro licence for V8, I need to be absolutely sure everything is going to be ok.
I am quite happy to proceed with the purchase but there seems to be one last problem which I am sure could be a V8 bug.

If you haven't seen it its here
viewtopic.php?f=76&t=20638

If we can get an answer to this one I'll be more than happy to purchase V8 pro

Cheers

Iain
These users thanked the author iain wilkie for the post:
Benj (Tue Nov 20, 2018 6:20 pm)
Rating: 5.26%
 

User avatar
STibor
Posts: 262
Joined: Fri Dec 16, 2011 3:20 pm
Has thanked: 111 times
Been thanked: 112 times
Contact:

Re: Import old projects

Postby STibor » Tue Nov 20, 2018 5:40 pm

Benj wrote:Hello,

Do you have many files to upgrade? We recently removed v4 and v5 upgrade support from v8.1.

You can send me the files via PM and I will convert them to v8 for you.


Thanks!

I understand how difficult it is to hold together different software versions.
Old Flowcode versions are also installed (v5, v6 v7) due to old projects. I will convert v5 files with v6 to fcfx file format.
These users thanked the author STibor for the post:
Benj (Tue Nov 20, 2018 6:20 pm)
Rating: 5.26%