Disappearing Window

Moderator: Benj

Post Reply
chipfryer27
Posts: 221
Joined: Fri Jun 06, 2014 3:53 pm
Contact:

Disappearing Window

Post by chipfryer27 »

Hi

This is similar to another thread regarding displays. Like them, the problem is only with v8 no other software (or Flowcode version). It does not happen all the time but often enough for it to be troublesome.

I'm running W8.1.

With v8 running and I open another window within Flowcode (say Build>Project Options) the new window immediately disappears. If I click on the Main Flowcode area the window reappears again but if I try and click on it, it disappears again. Like in a loop I have much "fun" until I need to forcibly stop Flowcode from running. Starting it again cures for a while.

Other times, when I click on the main window in the hope of the other reappearing, it does but appears / disappears like a strobe.

Windows tells me I am up to date and I'm using a laptop with bog standard drivers. Nothing fancy here. As mentioned it is only v8 I have problems with.

Regards

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8928
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Contact:

Re: Disappearing Window

Post by medelec35 »

Hi, I believe V8 suffers from focus issues which I have reported.
Hopefully will be sorted with the next update?

However for your issue have you upgraded to the latest version, i.e 8.1.1.11?
If not, you can upgrade from hereas your issue should have been resolved with the latest fix.
Martin

chipfryer27
Posts: 221
Joined: Fri Jun 06, 2014 3:53 pm
Contact:

Re: Disappearing Window

Post by chipfryer27 »

Hi

Not long after I posted I discovered that upgrade whilst on the Matrix site. Since downloading it I haven't seen the issue return but as it is intermittent I was going to wait a day before updating my post. I didn't get it every session but I would get it every day. It also helped a little bit with another issue I'm having but didn't solve that one.

Thanks for your help (again), it is always appreciated. Due to work / travel I don't always get the chance to access the forum but I'm binge viewing now :)

Regards

chad
Posts: 154
Joined: Sun Nov 04, 2018 7:13 pm
Contact:

Re: Disappearing Window

Post by chad »

I ran into this tonight as well. I think it has to do with weather or not the flowcode window is maximized or not. If it is maximized it seems to be ok. If it is in windowed mode I have to play hide and seek with the dialog box.

chad

chipfryer27
Posts: 221
Joined: Fri Jun 06, 2014 3:53 pm
Contact:

Re: Disappearing Window

Post by chipfryer27 »

Hi Chad

Did you try the update as Medelec suggested?

My version of Flowcode didn't tell me about the update, I found it on the website. Once updated I haven't yet had the issue return. Usually my window is running "slightly" minimised.

Regards

chad
Posts: 154
Joined: Sun Nov 04, 2018 7:13 pm
Contact:

Re: Disappearing Window

Post by chad »

Hi chip,

Yeah, I am running the latest. I thought it was fixed but tonight while making a new embedded project the bug happened again.
It isn't a big deal to me, I have bigger problems with FC than that. It has only failed for me once post update.

Chad

chipfryer27
Posts: 221
Joined: Fri Jun 06, 2014 3:53 pm
Contact:

Re: Disappearing Window

Post by chipfryer27 »

Hi

Just a quick update.

Since I manually updated (to v8.1.1.11) I have not had my issue return. I have opened multiple session of v8 and many sub-windows with no disappearing act.

For me I think my issue is resolved.

Regards and Happy New Year

EDIT >
It has been a week now and the issue has not returned :)

johnsondav
Posts: 186
Joined: Thu Jun 28, 2012 7:29 pm
Location: Durham
Contact:

Re: Disappearing Window

Post by johnsondav »

Hi Everyone

Well, I though I must be going daft. probably am, but where has all my display gone? They have for some reason disappeared from the 'Displays' and can now only be accessed via 'Misc' menu through the search option. This is very odd as I have done nothing to the settings. :(
FC8_Displays_Gone.png
(131.4 KiB) Downloaded 2192 times
I am using FC8.1.1.11 Built Dec 14 2018
Windows 10 1803 Pro OS 17134.523

If I remember correctly, FC8 did tell me that an update was available, although not for any display packs, before this problem occurred!
Hmmm.
Any suggestions would be greatly appreciated.

johnsondav
Posts: 186
Joined: Thu Jun 28, 2012 7:29 pm
Location: Durham
Contact:

Re: Disappearing Window

Post by johnsondav »

Well, I take that back. I have solved my own problem. There appears to be a miss-match when doing 'In Use' only updates. I have just done a full system update (using the up-date feature of FC8) and the problem has gone away. Yeh. :D
FC8_Displays.png
(129.43 KiB) Downloaded 2190 times
Dave

chipfryer27
Posts: 221
Joined: Fri Jun 06, 2014 3:53 pm
Contact:

Re: Disappearing Window

Post by chipfryer27 »

Hi

That caught me out too, the option for File-in-Use vs Full Database when updating :)

User avatar
Benj
Matrix Staff
Posts: 14873
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Contact:

Re: Disappearing Window

Post by Benj »

Hello,

Sorry for any confusion and glad you're all sorted again now..

We are currently having a bit of a clean up of the components and groupings which is what caused the displays to disappear. There is likely more changes to come in the next couple of weeks but hopefully we can make this as painless as possible for everyone.

Post Reply