Model 3D et AllCode

Forum de support pour les locuteurs de la langue française qui souhaitent écrire dans leur langue maternelle.

Moderator: Benj

Post Reply
sundgau
Posts: 78
Joined: Mon Sep 26, 2011 4:18 pm
Has thanked: 5 times
Been thanked: 10 times
Contact:

Model 3D et AllCode

Post by sundgau »

Bonjour,

J'aimerai rajouter un model 3D au allcode et qu'il bouge en même temps que lui lors des mouvements.
J'ai regroupé l'ensemble mais le Allcode bouge seul.
GIF.gif
GIF.gif (13.91 KiB) Viewed 14182 times
Comment faire bouger l'ensemble?

Merci d'avance

Bruno
Attachments
Allcode et objet.fcfx
(13.29 KiB) Downloaded 344 times

User avatar
Benj
Matrix Staff
Posts: 15312
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4803 times
Been thanked: 4314 times
Contact:

Re: Model 3D et AllCode

Post by Benj »

Bonjour Bruno,

C’est quelque chose pour lequel nous pouvons ajouter un soutien sans trop de problèmes.

Quelle version de Flowcode utilisez-vous et je vais étudier un moyen intéressant de permettre cela.




Hello Bruno,

This is something we can add support for without too much hassle.

Which version of Flowcode are you using and I will investigate a nice way of allowing for this.

User avatar
Benj
Matrix Staff
Posts: 15312
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4803 times
Been thanked: 4314 times
Contact:

Re: Model 3D et AllCode

Post by Benj »

J'ai ajouté une nouvelle propriété au composant dans FCv8 et cela peut être dirigé vers votre groupe contenant le FA et les nouveaux bits montés.
SimProps.jpg
SimProps.jpg (20.21 KiB) Viewed 14153 times
Espérons que cela devrait faire tout ce dont vous avez besoin.



I've added a new property to the component in FCv8 and this can be pointed to your group containing the FA and the new mounted bits.
SimProps.jpg
SimProps.jpg (20.21 KiB) Viewed 14153 times
Hopefully this should do everything you need.

sundgau
Posts: 78
Joined: Mon Sep 26, 2011 4:18 pm
Has thanked: 5 times
Been thanked: 10 times
Contact:

Re: Model 3D et AllCode

Post by sundgau »

Hi Benj,
Sorry for the delay. I only have V7 flowcode. Can you also do the manipulation for this version.
thank you in advance
Bruno

User avatar
Benj
Matrix Staff
Posts: 15312
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4803 times
Been thanked: 4314 times
Contact:

Re: Model 3D et AllCode

Post by Benj »

Hi Bruno,

I'm struggling to get the mod into the v7 component. I'll keep trying but so far it's throwing problems at me.

User avatar
Benj
Matrix Staff
Posts: 15312
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4803 times
Been thanked: 4314 times
Contact:

Re: Model 3D et AllCode

Post by Benj »

I ended up having to build the component with v8 so maybe make a backup of the file first just in case I have broken something fundemental.
FormulaAllCodeP4.fcpx
(308.6 KiB) Downloaded 345 times
The file lives here.

C:\Program Files (x86)\Flowcode 7\components\

Let me know how you get on.

sundgau
Posts: 78
Joined: Mon Sep 26, 2011 4:18 pm
Has thanked: 5 times
Been thanked: 10 times
Contact:

Re: Model 3D et AllCode

Post by sundgau »

Sorry but No "addon mechanics" with the new component on flowcode7!
Screen Shot 10-08-19 at 09.28 PM.PNG
(15.95 KiB) Downloaded 2979 times

User avatar
Benj
Matrix Staff
Posts: 15312
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4803 times
Been thanked: 4314 times
Contact:

Re: Model 3D et AllCode

Post by Benj »

Aha sorry I've spotted the problem now. This file should work correctly.
FormulaAllCodeP4.fcpx
(285.55 KiB) Downloaded 338 times

sundgau
Posts: 78
Joined: Mon Sep 26, 2011 4:18 pm
Has thanked: 5 times
Been thanked: 10 times
Contact:

Re: Model 3D et AllCode

Post by sundgau »

Hello Benj and sorry again!
The model has good addon mech but the objects do not follow the Allcode...

Bruno
Attachments
Screen Shot 10-09-19 at 09.25 PM.PNG
(4.62 KiB) Downloaded 2961 times
GIF.gif
GIF.gif (59.35 KiB) Viewed 14103 times

User avatar
Benj
Matrix Staff
Posts: 15312
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4803 times
Been thanked: 4314 times
Contact:

Re: Model 3D et AllCode

Post by Benj »

Thanks for letting me know. It's working for me in v8 so could be down to how you have grouped things. I just selected the FA and everything else I wanted to move with it and grouped them together.

Can you attach your program so I can see your grouping.

sundgau
Posts: 78
Joined: Mon Sep 26, 2011 4:18 pm
Has thanked: 5 times
Been thanked: 10 times
Contact:

Re: Model 3D et AllCode

Post by sundgau »

here it is.
Attachments
Flowcode1_testmodel3d avec allcode.fcfx
(14.64 KiB) Downloaded 329 times

User avatar
Benj
Matrix Staff
Posts: 15312
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4803 times
Been thanked: 4314 times
Contact:

Re: Model 3D et AllCode

Post by Benj »

Aha, thanks it's the logo commands that are not working with the group.

For now here's a prog that works :)
Flowcode1_testmodel3d avec allcode.fcfx
(14.24 KiB) Downloaded 307 times
I'll get this fixed but it will probably be tomorrow if that's ok, I'm out of the office today.

sundgau
Posts: 78
Joined: Mon Sep 26, 2011 4:18 pm
Has thanked: 5 times
Been thanked: 10 times
Contact:

Re: Model 3D et AllCode

Post by sundgau »

Yes, I had not tested the right macros!
It works now with all non-logo commands and the result is great. My students can now simulate their robot.
Yes, I had not tested the right macros!

BUT compliation no longer works to generate code C!
Erreurs au cours de la génération du code source C:
Flowcode1_testmodel3d avec allcode.c : 10312 : error : Composant inconnu ou absent: PWM_AudioOut1::Enable
Flowcode1_testmodel3d avec allcode.c : 10314 : error : Composant inconnu ou absent: PWM_AudioOut1::SetDuty10Bit
Flowcode1_testmodel3d avec allcode.c : 10342 : error : Composant inconnu ou absent: PWM_AudioOut1::Disable
Flowcode1_testmodel3d avec allcode.c : 10953 : error : Composant inconnu ou absent: LCD_Backlight::Enable
Flowcode1_testmodel3d avec allcode.c : 10957 : error : Composant inconnu ou absent: LCD_Backlight::Disable
Flowcode1_testmodel3d avec allcode.c : 10962 : error : Composant inconnu ou absent: LCD_Backlight::SetDuty8Bit
Flowcode1_testmodel3d avec allcode.c : 11194 : error : Composant inconnu ou absent: PWM_LeftMotorFW1::Enable
Flowcode1_testmodel3d avec allcode.c : 11196 : error : Composant inconnu ou absent: PWM_LeftMotorFW1::SetDuty8Bit
Flowcode1_testmodel3d avec allcode.c : 11204 : error : Composant inconnu ou absent: PWM_LeftMotorBW1::Enable
Flowcode1_testmodel3d avec allcode.c : 11206 : error : Composant inconnu ou absent: PWM_LeftMotorBW1::SetDuty8Bit
Flowcode1_testmodel3d avec allcode.c : 11233 : error : Composant inconnu ou absent: PWM_RightMotorFW1::Enable
Flowcode1_testmodel3d avec allcode.c : 11235 : error : Composant inconnu ou absent: PWM_RightMotorFW1::SetDuty8Bit
Flowcode1_testmodel3d avec allcode.c : 11243 : error : Composant inconnu ou absent: PWM_RightMotorBW1::Enable
Flowcode1_testmodel3d avec allcode.c : 11245 : error : Composant inconnu ou absent: PWM_RightMotorBW1::SetDuty8Bit
Flowcode1_testmodel3d avec allcode.c : 11445 : error : Composant inconnu ou absent: PWM_LeftMotorFW1::Enable
Flowcode1_testmodel3d avec allcode.c : 11447 : error : Composant inconnu ou absent: PWM_LeftMotorFW1::SetDuty8Bit
Flowcode1_testmodel3d avec allcode.c : 11457 : error : Composant inconnu ou absent: PWM_LeftMotorBW1::Enable
Flowcode1_testmodel3d avec allcode.c : 11459 : error : Composant inconnu ou absent: PWM_LeftMotorBW1::SetDuty8Bit
Flowcode1_testmodel3d avec allcode.c : 11491 : error : Composant inconnu ou absent: PWM_RightMotorFW1::Enable
Flowcode1_testmodel3d avec allcode.c : 11493 : error : Composant inconnu ou absent: PWM_RightMotorFW1::SetDuty8Bit
Flowcode1_testmodel3d avec allcode.c : 11503 : error : Composant inconnu ou absent: PWM_RightMotorBW1::Enable
Flowcode1_testmodel3d avec allcode.c : 11505 : error : Composant inconnu ou absent: PWM_RightMotorBW1::SetDuty8Bit
Flowcode1_testmodel3d avec allcode.c : 11830 : error : Composant inconnu ou absent: PWM_LeftMotorBW1::ChangePeriod
Bruno
Attachments
GIF2.gif
GIF2.gif (303.71 KiB) Viewed 14069 times

User avatar
Benj
Matrix Staff
Posts: 15312
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4803 times
Been thanked: 4314 times
Contact:

Re: Model 3D et AllCode

Post by Benj »

Hello,

Many thanks for letting me know. I have now added the functionality to the logo movement functions so hopefully these should work well now too.

I have looked into the compiling issue and beleive this has also been solved for you now.
FormulaAllCodeP4.fcpx
(335.66 KiB) Downloaded 277 times
Let me know how you get on.

sundgau
Posts: 78
Joined: Mon Sep 26, 2011 4:18 pm
Has thanked: 5 times
Been thanked: 10 times
Contact:

Re: Model 3D et AllCode

Post by sundgau »

Great, everything works fine on flowcode7.
Thank you very much for all this work.
Bruno

Post Reply