3 x 7 segmet multiplexing problem

For Flowcode users to discuss projects, flowcharts, and any other issues related to Flowcode 5.
To post in this forum you must have a registered copy of Flowcode 5 or higher.

Moderator: Benj

Post Reply
rashid khan
Posts: 2
Joined: Tue Dec 05, 2017 10:08 am
Contact:

3 x 7 segmet multiplexing problem

Post by rashid khan »

Dear All,

Initially we used 16f883 and got good results , later we realised that the memory of 16f883 is less than what we required , so we changed the microcontroller to 16f1936 , but we are now having issues of 1) 7 segment display not stable 2) flickering.

Please find attached flowcode file .

Thanks and regards
Rashid Khan
Attachments
R5.fcf
(31.06 KiB) Downloaded 80 times

User avatar
LeighM
Matrix Staff
Posts: 2050
Joined: Tue Jan 17, 2012 10:07 am
Contact:

Re: 3 x 7 segmet multiplexing problem

Post by LeighM »

You probably need to check your clock frequency, the default internal is quite slow, also differing time for execution paths could cause flicker.
Alternatively you could consider putting the digit strobes on a fixed time period interrupt.

User avatar
Benj
Matrix Staff
Posts: 14865
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Contact:

Re: 3 x 7 segmet multiplexing problem

Post by Benj »

It looks like the default intosc speed on the device is 500KHz.

You can speed up the device by adding a C code icon to the start of your program and also changing the clock speed in the project options.

16MHz

Code: Select all

osccon = 0x78;
32MHz

Code: Select all

osccon= 0xF0;
I've moved the topic to the Flowcode 5 forum topic as it's clearly not a v7 project.

rashid khan
Posts: 2
Joined: Tue Dec 05, 2017 10:08 am
Contact:

Re: 3 x 7 segmet multiplexing problem

Post by rashid khan »

Hi Benz / LeighM ,

Thanks for the inputs

We were using the internal oscillator , after we used a external oscillator (4Mhz) , the 7 segment display is now stable and flicker less .

Post Reply